Opened 10 years ago

Closed 9 years ago

#7411 closed defect (Unverified)

Problem with OSD losing it's place

Reported by: arizonamythtv@… Owned by: markk
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.22rc1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I'm not sure if this is the same bug.

http://svn.mythtv.org/trac/ticket/7197

What's throwing me is I have this problem with the Browse All Channels set to on.

I have a total of three tuners. 1) PVR150 2) Kworld ATSC-110 3) TV Wonder

Say I'm watching LiveTV on the PVR150 and then I select record. While I'm still watching livetv that is now being recorded, if I try to browse the channels on the OSD I'm only shown the ones from the Kworld OTA tuner and the ones from the TV wonder will not be displayed. The TV Wonder and the PVR 150 have their separate schedules direct source. If I open the EPG, the channels from the TV Wonder will be shown that is they're not greyed out. If I select one of these channels to use the TV Wonder, I'm taken to the channel. If I view this channel and I try to browse the OSD for this source, I run into major problems with the video being choppy and the OSD will not show at all and the remote stops responding thus I can't exit so I have to kill the frontend through ssh. Sometimes it also trashes lirc and I have to restart this as well.

Attachments (2)

tuner_bad.log (21.0 KB) - added by anonymous 10 years ago.
tuner_good.log (28.1 KB) - added by anonymous 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by anonymous

Attachment: tuner_bad.log added

Changed 10 years ago by anonymous

Attachment: tuner_good.log added

comment:1 Changed 10 years ago by arizonamythtv@…

Looks like it's an issue with the IsTunable? subroutine.

I have three tuners, tuner 1 pvr150, tuner 2 Kworld ATSC 110, tuner 3 Tv Wonder

Start LiveTV on tuner 1, OSD will only display info from tuner 2. (tuner_bad.log) Start LiveTV on tuner 3, OSD will display info from tuner 1 and tuner 2. (tuner_good.log)

comment:2 Changed 10 years ago by robertm

Milestone: 0.22unknown

comment:3 Changed 10 years ago by arizonamythtv@…

I turned browse all channels off and by changing the setting it at least makes the 3rd tuner usable while recording on tuner 1.

comment:4 Changed 9 years ago by robertm

Owner: changed from Isaac Richards to markk
Status: newassigned

Probably need to know if this still exists in current trunk post MythUI OSD merge.

comment:5 Changed 9 years ago by robertm

Status: assignedinfoneeded

comment:6 Changed 9 years ago by stuartm

Resolution: Unverified
Status: infoneededclosed

5 weeks without requested information being provided.

Note: See TracTickets for help on using tickets.