Opened 10 years ago

Closed 10 years ago

#7413 closed defect (fixed)

FE segfaults when in EPG

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: 0.23
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I chose manage recordings > schedule recordings > program guide. Went in to past time, chose a show that had been recorded. I get displayed the message about the show, that it has been recorded. If I try to do something else than exit, segfault is prone to happen.

mythtv@htpc:~$ mythbackend --version Please include all output in bug reports. MythTV Version : 22523M MythTV Branch : trunk Network Protocol : 50 Library API : 0.22.20091016-1 QT Version : 4.5.2 Options compiled in:

linux debug using_alsa using_backend using_dvb using_frontend using_hdpvr using_iptv using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Attachments (10)

gdb1.txt (90.5 KB) - added by tapio.sami@… 10 years ago.
myth1.log (146.4 KB) - added by tapio.sami@… 10 years ago.
gdb2.txt (25.5 KB) - added by tapio.sami@… 10 years ago.
myth2.log (40.3 KB) - added by tapio.sami@… 10 years ago.
gdb3.txt (32.4 KB) - added by tapio.sami@… 10 years ago.
myth3.log (45.8 KB) - added by tapio.sami@… 10 years ago.
gdb.txt (32.7 KB) - added by Sami Tapio <tapio.sami@…> 10 years ago.
Backtrace from RC version…
gdb.2.txt (16.6 KB) - added by Sami Tapio <tapio.sami@…> 10 years ago.
on mythbuntu
myth.log (260.8 KB) - added by Sami Tapio <tapio.sami@…> 10 years ago.
on mythbuntu
backtraces to 7413.2.txt (13.9 KB) - added by tapio.sami@… 10 years ago.
backtraces

Download all attachments as: .zip

Change History (17)

Changed 10 years ago by tapio.sami@…

Attachment: gdb1.txt added

Changed 10 years ago by tapio.sami@…

Attachment: myth1.log added

Changed 10 years ago by tapio.sami@…

Attachment: gdb2.txt added

Changed 10 years ago by tapio.sami@…

Attachment: myth2.log added

Changed 10 years ago by tapio.sami@…

Attachment: gdb3.txt added

Changed 10 years ago by tapio.sami@…

Attachment: myth3.log added

comment:1 Changed 10 years ago by Sami Tapio <tapio.sami@…>

Happens also with:

mythtv@htpc:~$ mythbackend --version Please include all output in bug reports. MythTV Version : 22582 MythTV Branch : branches/release-0-22-fixes Network Protocol : 50 Library API : 0.22.20091023-1 QT Version : 4.5.2 Options compiled in:

linux debug using_alsa using_backend using_dvb using_frontend using_hdpvr using_iptv using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Don't know if additional backtrace is needed, so I leave one.

Changed 10 years ago by Sami Tapio <tapio.sami@…>

Attachment: gdb.txt added

Backtrace from RC version...

comment:2 Changed 10 years ago by Sami Tapio <tapio.sami@…>

After some suggestions to the functioning of my distro (Debian), I followed the suggestions to try for example mythbuntu. I have built myth on mythbuntu 9.10, here is the info. To the user, this segfault happens same way as on debian.

mythtv@htpc:~$ mythbackend --version Please include all output in bug reports. MythTV Version : 22721 MythTV Branch : branches/release-0-22-fixes Network Protocol : 50 Library API : 0.22.20091023-1 QT Version : 4.5.2 Options compiled in:

linux debug using_alsa using_pulse using_backend using_dvb using_frontend using_hdpvr using_iptv using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Changed 10 years ago by Sami Tapio <tapio.sami@…>

Attachment: gdb.2.txt added

on mythbuntu

Changed 10 years ago by Sami Tapio <tapio.sami@…>

Attachment: myth.log added

on mythbuntu

comment:3 Changed 10 years ago by paulh

Resolution: worksforme
Status: newclosed
Version: unknownhead

I can't reproduce this in current trunk.

Changed 10 years ago by tapio.sami@…

Attachment: backtraces to 7413.2.txt added

backtraces

comment:4 Changed 10 years ago by tapio.sami@…

mythfrontend --version

Please include all output in bug reports. MythTV Version : 23197 MythTV Branch : trunk Network Protocol : 56 Library API : 0.23.20100115-1 QT Version : 4.5.2 Options compiled in:

linux debug using_alsa using_pulse using_pulseoutput using_backend using_directfb using_dvb using_frontend using_hdpvr using_iptv using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Check the attached backtraces.

comment:5 Changed 10 years ago by paulh

Milestone: unknown0.23
Resolution: worksforme
Status: closednew

OK, I think I see what the problem is now. Am I correct you only see the bug if you try to exit the dialog by pressing the right arrow?

comment:6 Changed 10 years ago by tapio.sami@…

Yes, you are correct. I did not previously see that it was right arrow causing it... too fast hitting keys, I suppose...

comment:7 Changed 10 years ago by paulh

Resolution: fixed
Status: newclosed

(In [23224]) Fix a segfault when right arrow is pressed on a pop-up menu if it doesn't have any items. Fixes #7413.

Note: See TracTickets for help on using tickets.