Opened 10 years ago

Closed 10 years ago

#7418 closed defect (worksforme)

mythfrontend refuses to run after daylight save time change

Reported by: voyo Owned by: sphery
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.22rc1
Severity: medium Keywords: time zone daylight saving
Cc: Ticket locked: no

Description

Time was changed by NTP daemon, (from 3am to 2am), after rebooting moment later mythfronted wont run anymore.

backend and frontend are running on SAME machine !

2009-10-25 02:06:30.215 MythContext: Connecting to backend server: 10.0.0.200:6543 (try 1 of 1) 2009-10-25 02:06:30.235 Using protocol version 50 2009-10-25 02:06:30.281 UTC offset on the master backend differs from offset on this system. 2009-10-25 02:06:30.281 Detected time zone settings:

Master: Zone ID: 'Europe/Warsaw?', UTC Offset: '3600', Current Time: '2009-10-25T02:06:30'

Local: Zone ID: 'Europe/Warsaw?', UTC Offset: '7200', Current Time: '2009-10-25T02:06:30'

2009-10-25 02:06:30.281 The time and/or time zone settings on this system do not match those in use on the master backend. Please ensure all frontend and backend systems are configured to use the same time zone and have the current time properly set. 2009-10-25 02:06:30.281 Unable to run with invalid time settings. Exiting.

MythTV Version : 22512M MythTV Branch : trunk Network Protocol : 50 Library API : 0.22.20091016-1 QT Version : 4.4.3 Options compiled in:

linux release using_oss using_alsa using_arts using_backend using_directfb using_dvb using_frontend using_hdpvr using_iptv using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_live using_mheg

Change History (5)

comment:1 Changed 10 years ago by sphery

Owner: changed from Isaac Richards to sphery
Status: newaccepted

Your frontend should start just fine, now (after the 2nd coming of 3:00am). I'm looking into why the 2 apps running the same function got different results from Qt during the 1 hour of redundant times.

comment:2 Changed 10 years ago by voyo

yes, confirmed. I just wanted to update ticket. After 3:00am its working again.

I did grep trough all files in mythtv trunk src directory, and I didnt found any message like "offset on the master backend differs from offset on this system" ??

let me know if you need some more info.

comment:3 Changed 10 years ago by sphery

Priority: criticalminor

comment:4 Changed 10 years ago by sphery

Status: acceptedinfoneeded
Summary: mythfrontent refuses to run after daylight save time changemythfrontend refuses to run after daylight save time change

voyo and andreax, do you by any chance have your systems set to store local time in the hardware clock rather than storing UTC? Is it possible that your backend and frontend are running in environments where the time zone differs? (I realize that the myth logs say they're in the same time zone, but it's possible your system may be configuring time zone through a mechanism we're not handling.) If so, do you happen to know how the time zone was configured in the "different" environment (seemingly the one in which the frontend was running as it didn't see the DST switch until an hour later).

I just did a test run on my system and could not reproduce the issue. I had no problems starting mythfrontend during the "redundant" time period. Both the backend and frontend saw my UTC offset change from 14400 to 18000 after the time change.

I tested with the upcoming US/Eastern aka America/New_York time change that will occur on Sun, Nov 1, 2009 at 2:00am EDT. Test was with a single combined backend/frontend system. I left mythbackend and mythfrontend running through the time change and both continued to work without issue after the change. I then shut down mythfrontend and restarted it several times without issues.

comment:5 Changed 10 years ago by robertm

Resolution: worksforme
Status: infoneededclosed

No response in 1/4 of a year.

Note: See TracTickets for help on using tickets.