Opened 14 years ago

Closed 12 years ago

Last modified 12 years ago

#745 closed defect (wontfix)

PVR-350 FF/REW >3x doesn't update frames

Reported by: anonymous Owned by: Isaac Richards
Priority: trivial Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

When using a PVR-350 for video out (and using the PVR-350 MPEG decoder), Fast Forward and Rewind at speeds greater than 3x are very jumpy, and when you leave the FF/REW mode and go back to Play you are taken back to the point you started from. This is with the Gentoo portage 0.4.0-r2 stable ivtv driver.

Attachments (2)

mythbackend.log (13.4 KB) - added by mythtv@… 14 years ago.
mythbackend.log for ticket #745
mythfrontend.log (99.3 KB) - added by mythtv@… 14 years ago.
mythfrontend.log for ticket #745

Download all attachments as: .zip

Change History (42)

comment:1 Changed 14 years ago by anonymous

Version: 0.18.1head

This happens with recent svn versions as well.

comment:2 Changed 14 years ago by danielk

Are you sure you are using PVR-350 video out and not XVideo out?

comment:3 Changed 14 years ago by danielk

Milestone: unknown
Owner: changed from Isaac Richards to danielk

comment:4 Changed 14 years ago by mythtv@…

I just tried this with svn v8465. I am using the PVR-350 out (I have "Use the PVR-350s TV out/MPEG decoder" checked in TV Settings->Playback).

The results are similar to what is reported above, or worse. 3x speed seems to work fine, and the counter advances with a fast picture. At faster speeds the picture just freezes while the counter goes faster, and when I come out of FF it jumps back to the start point. After a few tests the whole thing went wonky and now I just get a full green screen when trying to play back anything or watch Live TV. The menus and preview still work fine. This may be an ivtv issue rather than MythTV, however.

This is on a combo frontend/backend box with kernel 2.6.11-gentoo-r9 and ivtv 0.4.0-r3 from portage. Let me know if any logs would be helpful (and which.)

Daniel Segel

comment:5 Changed 14 years ago by jasonmollman@…

I can also confirm this behavior. I too am using a PVR-350, Fedora Core 3, IVTV 0.4.1. I have seen this back to ivtv 0.3.7.

comment:6 Changed 14 years ago by danielk

Does "Using the PVR-350 decoder/TV-out" get printed to the console?

Before and after things go "wonky" ?

comment:7 Changed 14 years ago by mythtv@…

I just tried it again, and this time I get the following behavior:

3X FF works fine

5X FF seems to work - time advances and when I exit FF I am at a position farther into the recording, but the image onscreen is frozen during the actual FF so I can't tell exactly where I am.

I didn't get to the green screen because I only tried a few experiments. It takes a lot of FF/REW, in and out of recordings to get the green screen up.

I have the following in my mythfrontend output log:

2006-01-02 19:40:47.650 Using the PVR-350 decoder/TV-out

I could send the entire log section for the period when I was quickly testing this yesterday if you'd like.

comment:8 Changed 14 years ago by danielk

Please 'Attach File' the backend log with '-v record' and the frontend log with '-v playback'

I believe the green screen issue you saw is fixed in SVN, I believe it was falling back to XVideo when it failed to open PVR-350 output.

Changed 14 years ago by mythtv@…

Attachment: mythbackend.log added

mythbackend.log for ticket #745

Changed 14 years ago by mythtv@…

Attachment: mythfrontend.log added

mythfrontend.log for ticket #745

comment:9 Changed 14 years ago by mythtv@…

I've attached my mythbackend.log and mythfrontend.log set up with -v record and playback, respectively. I recorded a 30-minute show, then went in to watch it when it was over and used FF at 3x, 5x, and 10x speed. 3x works fine, but with 5x and 10x the image freezes during the FF, although it does seem to be moving to the correct point (i.e. when I exit FF I think I'm at the correct spot) and the time counter is now advances at what seems to be a correct speed (I didn't actually time it to see.)

In summary, the only problem I'm seeing now is that the image is freezing during the 5x or faster FF.

This is all with svn revision 8565.

comment:10 Changed 14 years ago by danielk

Status: newassigned
Summary: Fast Forward and Rewind on PVR-350 are jumpy and exiting takes you to the wrong pointPVR-350 FF/REW >3x doesn't update frames

I can reproduce the FF/REW >3x no update problem, I will try to fix this.

comment:11 Changed 14 years ago by danielk

Milestone: unknown0.20
Status: assignednew

None of the obvious fixes for this worked.

I'm pushing this to 0.20, I'll have a look at this again later if no one beats me to it.

comment:12 Changed 14 years ago by smp@…

I'm seeing the 'picture freezes using fast forward > 3x' bug in this setup:

Kernel 2.6.15.4

ivtv 0.4.3

mythtv 0.19

pvr-350

Anything I can do to help ?

comment:13 Changed 14 years ago by bluesguy_1@…

I'm getting this as well. This functionality worked fine under Myth .18.1. I could ff or rw at 3x/5x/10x/16x and it would display video frames as it was seeking. Under .19 this is broken at anything faster than 3x. The recording does advance (or rewind), but no video frames are displayed, just a frozen image. Nothing else in my configuration changed, so it would appear at first glance to be a Myth bug.

Kernel 2.6.12-1.1380_FC3 ivtv 0.4.0 pvr-350 Mythtv .18.1 -> .19

I can provide log output if it helps.

comment:14 Changed 14 years ago by joe.breen@…

Also seeing this problem with 0.19 and a PVR-350. Found this posting while searching for an answer.

comment:15 Changed 14 years ago by Guyfromhe

I also see this behavior using the pvr-350 anything faster than 3x Rew or FF using the PVR350 tv out, it used to work until I upgraded to 0.19, it seems to advance fine but the picture doesn't update while it's doing so, just the bar.

comment:16 Changed 14 years ago by ll cool jeff at gmail dot com

Milestone: 0.200.19
Priority: minormajor
Severity: mediumhigh

Can any of the developers shed some light on this issue? What has changed with the fast forward / rewind code that could affect the PVR-350? It was working fine in 0.18, and it's completely broken in 0.19 (3x fast forward actually works better, but rewind and any other speeds don't work at all.)

comment:17 Changed 14 years ago by danielk

Milestone: 0.190.20
Priority: majortrivial
Severity: highlow

Jeff, we will probably drop support for PVR-350 output unless someone steps up to maintain it.

comment:18 Changed 14 years ago by james

I would step up to maintain it if I could, but I'm just not that capable. I hope someone does because I'll be stuck on 0.18 for a long time. I get the impression that I'm not the only one completely relying on PVR-350 out to use MythTV from reading different lists, etc.

comment:19 Changed 14 years ago by joe.breen@…

I'm also not that capable, but I'd like to try and help out. I wouldn't want to see support for my hardware go away! I'll look into it after my upcoming medical school exam this week!

comment:20 Changed 14 years ago by mac

I am affected by this also going from 0.18 to 0.19. Same story FF/REW > 3X / PVR-350 TV-out.

Poking around, it looks like the problem might be in: libmythtv/ivtvdecoder.cpp or libmythtv/videoout_ivtv.cpp

comment:21 Changed 14 years ago by gtaylor+mythtv@…

Ah, I have a 50% different setup but seem to be experiencing the same bug, so I'll add my details in case it's helpful.

My setup is PVR-150, output on a regular video card with just Xv. I observe that I can chose either mpeg2 decoder library (avcodec or ffmeg, is it?) and get the same problem. I also observe that the issue is particular to pre-transcoded recordings; after transcode to mpeg4 FF/REW works perfectly.

My svn is rusty, but I appear to be running 9263 from release-0.19-fixes around Mar 4.

comment:22 Changed 14 years ago by Marcus

I have the same problem with PVR-150 and regular output to my monitor, so it's probably not a problem with the tv-out of the PVR-350, but rather of the mpeg captured by the PVR-150/350.

I'm running the lastest version of 0.19 in Gentoo.

comment:23 Changed 14 years ago by kellrott@…

I've had a simular problem with a PVR-150. Seems to only effect pre-encoded shows, stuff that is still in MPEG2 format. Anything above 3x will fastforward for a few seconds, then freeze. If I hit fastforward again, it will bump up to the next speed and continue for a few more seconds. Once shows have been encoded I have no problems.

comment:24 Changed 14 years ago by mac

This is strange and I don't think everyone is talking about the same bug/bugs. With me - Mythtv 0.19 a PVR-350 and using TV-out and Ivtv-0.4.3.

I only see the bug with tvout. With output to a monitor - FF/Rew work fine, every direction every speed. With Tv-out I can FF 3X until the cows come home. Everything else and the counter advances while the video freezes. I have on tried transcoding because my myth box is quite slow. Hence the 350 with its hardware decoder.

Does anyone using Mythtv 0.19 with a PVR-350 and TV-out not have this problem?

comment:25 Changed 14 years ago by mcooke at kiva net

I was just checking out the 0.19 release notes at: http://www.mythtv.org/wiki/index.php/Release_Notes_-_0.19

and found this under "Fixes" Fixed XvMC FF/RW > x3

Seems like too much of coincidence ;)

comment:26 Changed 14 years ago by Marcus

I've done some more experiments too see what's happening. When I fastforward > 3x, I get errors. Sometimes I just see artifacts in the image (boxes of contents appearing where it shouldn't appear). My guess is that this is mpeg artifacts caused by bad mpeg captured by my PVR-150 or bad decoding. Sometimes, however, the video starts jumping in time, showing pictures from the beginning of the video when I should be somewhere in the middle. And when I stop fastforwarding I found myself at a position earlier than where I started.

I don't know much about MPEG but maybe it's some artifact in the mpeg (decoding) that sometimes just appears as block artifacts in the picture and sometimes garbles the timing of the whole playback?

Note: I have never seen any problems during ordinary play, 3x ffw, or using 0.18.

comment:27 Changed 14 years ago by fales

I can confirm that I see the same issue as described by mac. PVR-350, Gentoo 2.6.10, MythTV 0.19, IVTV 4.3

TV-Out FF 3X works fine. Anything faster freezes image but OSD continues to update counter. Stopping FF resumes display at the new position (usually forward of where I was, but in some cases backwards)

comment:28 Changed 13 years ago by danielk

Owner: changed from danielk to Isaac Richards

Lent out my PVR-350...

comment:29 Changed 13 years ago by pepsi_max2k

forget the pvr-350, my nova-t does the same thing. any ff or rw > 3x will only show an updated image every second or so, and if you leave it going for longer than ~10 seconds it stops completely. again, it worked fine in 0.18 but not 0.19. kernel 2.6.16 i believe, no idea about the ivtv version but i'm sure you've got enough info already...

comment:30 in reply to:  29 Changed 13 years ago by anonymous

Replying to pepsi_max2k:

forget the pvr-350, my nova-t does the same thing.

sorry, i take that back, it seems to work fine on suse 10.1 (just updated from 10.0).

comment:31 Changed 13 years ago by cpinkham

Milestone: 0.20unknown

Don't think any of the core developers are using PVR-350 cards so I am not sure this will get fixed for 0.20. Moving to 'unknown' for now. If anyone objects they can change it back.

comment:32 Changed 13 years ago by anonymous

Milestone: unknown0.21

comment:33 Changed 13 years ago by anonymous

Milestone: 0.21unknown

comment:34 Changed 13 years ago by Abby Smith

So how does someone fix this? Where do I get the code to look at the bug? I know C pretty well and I have a pvr-350.

Rsvp,

Abby

comment:35 Changed 13 years ago by anonymous

I recently was forced to reinstall from scratch on my myth box (an old 700 MHz w/ a PVR-350), using Jarod's FC6 guide. Same defect is present when using the PVR-350 out, but when I disable 350 output in the MythTV options, a curious thing happens... the output quality appears to be unchanged, but ff/rew works great at all speeds and seeks/jumps are much snappier! Can anybody with a better understanding of Myth's inner workings figure out why this is the case? I don't think my pokey old processor (with only 192 of RAM!) could even come close to this kind of output unassisted by the 350, so could my setup be leveraging the decoder in some other way?

Jarod's guide - http://wilsonet.com/mythtv/fcmyth.php

comment:36 Changed 13 years ago by Marvin

I seem to be experiencing this bug on my Knoppmyth setup (Myth V.20). I do NOT however have a PVR-350. I have a PVR-500. I can fast forward at 3x but going any faster results in the screen freezing. Pushing fast forward again will cause it to unfreeze briefly while going to the next FF step (3x to 5x etc..) but within seconds it freezes again. Pressing Enter will resume playback from roughly the point where it froze. Pressing play as opposed to enter causes the screen to pause (not freeze) at roughly the screen where it was frozen. Pressing play a second time will resume playback.

Rewind freezes even at 3x within a few seconds and is completely unusable!

Top shows mythfrontend at over 50% cpu usage on an Athlon XP 2800+ while fast forwarding until the screen freezes at which point mythfrontend cpu usage drops to practically nothing.

comment:37 Changed 12 years ago by Carl

This looks pretty stale, but is there any hope of fixing it? I just put a newly acquired pvr-350 into an older machine and see this issue: FF only works at 3X. At 5X the counter advances but no new frames are displayed. Rewind is much worse - any attempt to rewind seems to hang up something - no new frames are ever displayed till the frontend is restarted. This is using mythbuntu Gutsy.

Its too bad because this machine (a Celeron 466) can easily handle the job otherwise with this card.

Any word on what changed between 0.18 and 0.20 that might have caused it?

comment:38 Changed 12 years ago by danielk

Resolution: wontfix
Status: newclosed

No devs use PVR-350 playback, this is not going to get fixed unless someone submits a patch...

comment:39 Changed 12 years ago by me.mythtv@…

I might be willing to provide a PV4-350 to a developer if someone was interested in looking into the hang.

Is that a possibility?

comment:40 in reply to:  39 Changed 12 years ago by me.mythtv@…

Replying to me.mythtv@cgf.cx:

I might be willing to provide a PV4-350 to a developer if someone was interested in looking into the hang.

Is that a possibility?

btw, provide == donate.

Note: See TracTickets for help on using tickets.