Opened 10 years ago

Closed 10 years ago

#7456 closed defect (invalid)

mythfilldatabase (tv_grab_uk_rt) fails due to missing icons

Reported by: fatgerman@… Owned by: stuartm
Priority: major Milestone: unknown
Component: MythTV - Mythfilldatabase Version: 0.22rc1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Just installed mythbuntu 9.10, fresh installation. I've set up a listings source to use xmltv, tv_grab_uk_rt, using the 'Freeview' preset. When I run mythfilldatabase it retrieves all the data, but then when trying to update the database it crashes.

Last few lines from mythfilldatabase -v all (with datestamps removed becasue I'm copying this off my TV screen, not copying and pasting):

getHttp: grabbing: 'http://www.lyngsat-logo.com/logo/tv/uu/uktv_dave.jpg' HttpComms::stateChanged: connecting (2) ICE default IO error handler doing an exit(), pid = 6014, errno = 32

The problem is that the logo referenced by that URL doesn't exist, and it comes up with a 'Page Not Found' error instead. There are several of these errors and I've slowly been going through them and editing ~/.xmltv/supplement/tv_grab_uk_rt/channel_ids and correcting them where I can or removing them where I can't. Every time I do one it gets past that point only to fail on a later one.

So far I've gone through replacing: bbc1.jpg with bbc_one.jpg bbcparliament.jpg with bbc_parliament.jpg channel4_plus1.jpg with channel4.jpg uu/uktv_dave.jpg with dd/dave.jpg and had to remove any references to an icon for CNN, as it didn't like anything I put in there.

Now it finally gets to the end but then: IconData?: Updating icons for sourceid: 1 MSqlQuery::exec() "SELECT ch.chanid, nim.url FROM (channel ch, callsignnetworkmap csm) RIGHT JOIN networkiconmap nim ON csm.network = nim.network WHERE ch.callsign AND (icon = 'none' OR icon = ) AND ch.sourceid = '1'" ICE default IO error handler doing an exit(), pid = 6040, errno = 32

And I still have no listings data.

Perhaps worth mentioning that I've already downloaded channel icons in the Channel Editor in the backend setup, and that retrievied icons for every channel, so I already have them all anyway.

Surely mythfilldatabase shouldn't exit when it fails to retrieve an icon? I don't think anyone in the UK will be able to use mythtv at the moment because of this.

Change History (4)

comment:1 Changed 10 years ago by fatgerman@…

OK, deleting ~/.ICEAuthority solved this. Just not sure what created that file, since I've only run a couple of programs on it so far. If I find out, I'll post back.

comment:2 Changed 10 years ago by sphery

Resolution: invalid
Status: newclosed

See also http://svn.mythtv.org/trac/ticket/6257#comment:4 for another symptom.

Thanks for the quick response.

comment:3 Changed 10 years ago by mythtv@…

Resolution: invalid
Status: closednew

This is my first install of Mythbuntu 9.10 (x86) and I have this exact same error (also using tv_grab_uk_rt). I renamed ~/.ICEAuthority after reading the resolution above and that worked. Thanks for that tip! I will reopen this bug as it clearly is not specific to the submitter.

comment:4 Changed 10 years ago by stuartm

Resolution: invalid
Status: newclosed

If renaming .ICEAuthority fixes it, then it's not a mythtv bug but a problem with the wider environment.

Note: See TracTickets for help on using tickets.