Opened 10 years ago

Closed 9 years ago

#7457 closed defect (fixed)

mythfrontend crashes when I start metadata download then exit mythvideo

Reported by: ryan.goat@… Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: Plugin - MythVideo Version: 0.22rc1
Severity: medium Keywords: mythvideo metadata
Cc: Ticket locked: no

Description

In mythvideo I highlight a TV episode press <i><metadata options><download metadata>. That shows me a list of titles. I choose the correct one. Myth starts running a ttvdb.py command to grab the metadata. Then if I press <Esc> to go back to leave mythvideo and go back to the main menu mythfrontend aborts.

2009-10-30 17:17:46.433 Loading menu theme from /usr/share/mythtv/themes/defaultmenu//library.xml
2009-10-30 17:17:49.597 Loading window theme from /usr/share/mythtv/themes/Graphite/video-ui.xml
2009-10-30 17:17:56.749 Video Search: Executing "'/usr/share/mythtv/mythvideo/scripts/ttvdb.py' -M House"
2009-10-30 17:17:56.879 GetVideoList returned 100 possible matches
2009-10-30 17:17:56.879 Loading window theme from /usr/share/mythtv/themes/Graphite/video-ui.xml
2009-10-30 17:17:57.695 Video Data Query: Executing "'/usr/share/mythtv/mythvideo/scripts/ttvdb.py' -mD 73255 6 5"
QProcess: Destroyed while process is still running.
2009-10-30 17:17:59.416 "/usr/share/mythtv/mythvideo/scripts/ttvdb.py" failed: Process error 1
pure virtual method called
terminate called without an active exception
Aborted
#

MythTV Version : 22659 MythTV Branch : branches/release-0-22-fixes Network Protocol : 50 Library API : 0.22.20091023-1 QT Version : 4.5.0 Options compiled in:

linux release using_oss using_alsa using_backend using_directfb using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Attachments (2)

gdb1.txt (16.5 KB) - added by ryan.goat@… 10 years ago.
backtrace showing the failure
gdb.txt (16.5 KB) - added by anonymous 10 years ago.
backtrace with debug symbols

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by robertm

Status: newinfoneeded_new

This looks like a Qt crash-- backtrace please?

Changed 10 years ago by ryan.goat@…

Attachment: gdb1.txt added

backtrace showing the failure

comment:2 Changed 10 years ago by ryan.goat@…

I followed the instructions in the online documentations and made a backtrace with gdb. But it is my first time so I'm not 100% certain I ended it correctly. gdb said the program was still running when I quit.

comment:3 Changed 10 years ago by robertm

Sorry, you need to compile Myth with debug symbols for the backtrace to be of any use-- try compiling with --compile-type=debug and then create the backtrace again. If you are using packaged myth then you will need to either compile yourself or see if they provide debug packages.

Still, what little there is of the BT indicates strongly that the crash is not in myth.

comment:4 Changed 10 years ago by ryan.goat@…

I did recompile myth with the --compile-type=debug switch

Script started on Fri 30 Oct 2009 05:31:18 PM EDT
# Basic Settings

Compile type              debug

Compiler cache            no

DistCC                    no

qmake                     /usr/bin/qmake-qt4

install prefix            /usr

runtime prefix            /usr

CPU                       x86 x86_64 (model name	: Intel(R) Core(TM)2 Quad CPU    Q9400  @ 2.66GHz)

big-endian                no

runtime cpu detection     no

yasm                      no

MMX enabled               yes

MMX2 enabled              yes

3DNow! enabled            yes

3DNow! extended enabled   yes

SSE enabled               yes

SSSE3 enabled             yes

CMOV enabled              yes



# Input Support

Joystick menu             yes

lirc support              yes

Video4Linux sup.          yes

ivtv support              yes

HD-PVR support            yes

FireWire support          no

DVB support               yes [/usr/include]

DVB-S2 support            no

HDHomeRun support         yes

IPTV support              yes



# Sound Output Support

PulseAudio support        no

OSS support               yes

ALSA support              yes

aRts support              no

JACK support              no

libfftw3 support          no



# Video Output Support

x11 support               yes

xrandr support            yes

xv support                yes

XvMC support              no

XvMC VLD support          no

XvMC pro support          no

XvMC libs                 -lchromeXvMC

VDPAU support             yes

OpenGL video              yes

OpenGL vsync              yes

DirectFB                  yes

Fribidi formatting        no

MHEG support              yes



# Misc Features

multi threaded libavcodec yes

Frontend                  yes

Backend                   yes



# Bindings

bindings_perl             yes

bindings_python           yes



Creating libs/libmythdb/mythconfig.h and libs/libmythdb/mythconfig.mak



WARNING: When using --enable-proc-opt you must include the 

         output of ./configure along with any bug report.



libs/libmythdb/mythconfig.h is unchanged


Script done on Fri 30 Oct 2009 05:31:23 PM EDT

comment:5 Changed 10 years ago by robertm

You might have compiled it, but the installed/running version isn't a debug version. :)

That's what all the "no debug symbols" lines are...

Changed 10 years ago by anonymous

Attachment: gdb.txt added

backtrace with debug symbols

comment:6 Changed 10 years ago by anonymous

This was quite easy for me to reproduce, I first noticed it when the tmdb servers were down. Hitting escape during a meta-data inquirey causes this error.

Steps I used to reproduce - In mythvideo reset meta-data for a video. Press the "w" key to grab meta-data. Hit escape a few times in an atempt to abort the process. Segfault.

comment:7 Changed 10 years ago by robertm

Status: infoneeded_newnew

comment:8 Changed 9 years ago by robertm

Resolution: fixed
Status: newclosed

Should no longer be possible with the new metadata handling code-- Exiting mythvideo with a metadata grab in progress will wait for the thread to close.

Note: See TracTickets for help on using tickets.