Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7481 closed defect (fixed)

Video suttering on ZDF HD and ARD HD on Astra ( LiveTv and Playback )

Reported by: satfan39 Owned by: Janne Grunau
Priority: minor Milestone: 0.23
Component: MythTV - Video Playback Version: head
Severity: medium Keywords: upstream ffmpeg
Cc: Ticket locked: yes

Description

I run svn 22681 and I have no problem to receive astra dvb-s2 HD channels such Astra+ HD, Arte HD or the French, Spanish, Italian HD or even German HD channels sur as EinsFestival? HD or ORF1 HD. My CPU is an dual core E05350 an does not exceed 50% CPU, much lesser when I use vdpau instead of XV, so CPU power is not the issue here.

For ARD 1 HD and ZDF HD, video is suttering although CPU utilisation does not exceed 50% with XV. Same suttering problems when I used vdpau ( nvidia 8400gs ). Tried different deinterlacers and renderers but the problem persists ( little or no effects )

I was able to watch the recorded ZDF HD and ARD HD transmissions without any suttering at all using an external VLC player.. so this points to a problem with the internal player of Myth. Tried to play the recordings with an external mplayer player but it failed, the video didn' even start. Finally, tried with xine and it worked partially ( audio was terrible cracking an suttering ).

I will post the mythtv log and possibly also the mplayer log.

Attachments (5)

log_mythfrontend (5.5 KB) - added by anonymous 10 years ago.
log_good_vlc_payback (2.4 KB) - added by anonymous 10 years ago.
log_unscessfull_mplayer_playback (5.2 KB) - added by anonymous 10 years ago.
log_unsuccessful_xine_playback (8.4 KB) - added by anonymous 10 years ago.
libavformat.diff (484 bytes) - added by anonymous 10 years ago.
patch to fix judder for german 720p HDTV channels (ARTE HD, ZDF HD, EinsFestival? HD)

Download all attachments as: .zip

Change History (18)

Changed 10 years ago by anonymous

Attachment: log_mythfrontend added

Changed 10 years ago by anonymous

Attachment: log_good_vlc_payback added

Changed 10 years ago by anonymous

comment:1 Changed 10 years ago by anonymous

Hi i have the same Problem 1080i Videos works fine...

Changed 10 years ago by anonymous

comment:2 Changed 10 years ago by satfan39

The 4 logs attached were taken from the same mythtv recording on ARD 1 HD ( FTA channel on Astra 19E)

  • log_mythfrontend shows that there are my prebuffering with the transmission on ARD 1 HD, it works ( livetv & playback ) but image i unstable and sutters nearly permanently
  • log_good_vlc_play_back shows a perfect playback from the same file using an external VLC player !

-log_unsucessfull_mplayer_playback shows that mplayer did start to play the file for a very short period of time but then stopped.

  • logunsucessfull_xine_playback shows that for this same recording xine could not play the file ( first frame is no key frame !).

comment:3 Changed 10 years ago by satfan39

Please note that according to my my latest test, this problem also occurs with EinsFestival? HD, so in fact the only HD german channel where this problem does not exist is ORF 1 HD.

No problem: ORF1 HD

Problem; ZDF-HD ARD-HD Einsfestival HD

comment:4 Changed 10 years ago by anonymous

It seems to be a (H264-)decoder problem because CoreAVC-Decoder works fine (when porting to MythTV 0.22). But on the other side the H264-decoder-sources of Myth0.22 and Mplayer are identical (last week) but mplayer seems to be work.

Corious is that recordings of EinsFestivalHD from middle of september generates no problems but current recordings of EinsFestivalHD (with the same videoloop) have problems.

Another point is that current recordings of EinsFestivalHD freeze MythTV 0.21 completely (only kill helps). Using CoreAVC only are not enough here. There is the need to backport the HandleH264PrePkt of avformatdecoder.cpp from MythTV 0.22. This function handles among other things the GOP-management.

So the idea is that changes in the parameters of H264-codec and especially in the GOP-management is the cause for this problem.

If there is interest I can submit current CoreAVC-patches for 0.21 and 0.22 and can send the recordings of EinsFestivalHD from middle of september and end of october. Let me know.

Changed 10 years ago by anonymous

Attachment: libavformat.diff added

patch to fix judder for german 720p HDTV channels (ARTE HD, ZDF HD, EinsFestival? HD)

comment:5 Changed 10 years ago by anonymous

The patch before should fix the effects with german 720p HDTV channels (ARTE HD, Das Erste HD, ZDF HD and EinsFestivalHD). It is a part of a sync to current ffmpeg-svn and affects only one line in utils.c of libavformat. It helps here successfully.

comment:6 Changed 10 years ago by anonymous

I tested this patch, and it seems to work, and solve all problems with german 720p channels. I have noticed no side effects so far. Is there any chance to get this into .22-fixes?

comment:7 in reply to:  6 Changed 10 years ago by anonymous

I had the same problem with ARD HD, ZDF HD and ARTE HD via DVB-C from our local cable provider "GGA Pratteln" in Switzerland. I can confirm that the posted patch solves it.

Ticket #7522 looks similar. I tried both patches from there before. However, they only reduced the stuttering but didn't remove it completely.

comment:8 Changed 10 years ago by anonymous

How is this patch applied?

comment:9 Changed 10 years ago by stuartm

Ticket locked: set

Discussion belongs in the mailing lists NOT trac.

comment:10 Changed 10 years ago by stuartm

Component: MythTV - GeneralMythTV - Video Playback
Owner: changed from Isaac Richards to Janne Grunau

comment:11 Changed 10 years ago by Stuart Auchterlonie

Keywords: upstream ffmpeg added
Milestone: unknown0.23
Version: unknownhead

This appears to be fixed in upstream ffmpeg. This would be fixed by the next ffmpeg resync

Stuart

comment:12 Changed 10 years ago by Janne Grunau

Resolution: duplicate
Status: newclosed

duplicate of #7522

comment:13 Changed 10 years ago by Janne Grunau

Resolution: duplicatefixed

(In [23516]) libavformat: backport ffmpeg changeset 20160, Fixes #7481

Note: See TracTickets for help on using tickets.