Opened 10 years ago

Closed 10 years ago

#7487 closed defect (invalid)

MythVideo ignoring directories/files with non-ascii characters

Reported by: Robin Hill <myth@…> Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: Plugin - MythVideo Version: 0.22rc1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

MythVideo? scan is failing to find directories/files with non-ascii characters (e.g. é, ö). Also, if the directory is named using ASCII characters but the series title isn't, artwork is downloaded but not displayed.

MythTV Version : 22619M
MythTV Branch : branches/release-0-22-fixes
Network Protocol : 50
Library API : 0.22.20091023-1
QT Version : 4.5.2
Options compiled in:

linux release using_oss using_alsa using_backend using_dvb using_frontend using_iptv using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_live using_mheg

Attachments (2)

mythbackend.log (697 bytes) - added by Robin Hill <myth@…> 10 years ago.
Section of backend log showing scan of directory
test.cpp (647 bytes) - added by Robin Hill <myth@…> 10 years ago.
Simple test script using the same functionality

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Robin Hill <myth@…>

I've had a further dig into this (adding "file,extra" to the backend verbose settings), and the problem is that the entries are not in the QFileInfoList in StorageGroup::GetFileInfoList?. I can't work out why though, as I've written a small application which uses the same logic and that does list all the files/directories.

comment:2 Changed 10 years ago by cpinkham

I'm unable to reproduce this, can you attach the relevant part of the backend logs when running mythbackend with "-v file,extra,network". That will list out the directory being scanned and files/subdirs found as they are added to the result list. I want to see the requests coming into the backend from the frontend as well as the StorageGroup? logs when it did the directory scan.

Changed 10 years ago by Robin Hill <myth@…>

Attachment: mythbackend.log added

Section of backend log showing scan of directory

Changed 10 years ago by Robin Hill <myth@…>

Attachment: test.cpp added

Simple test script using the same functionality

comment:3 Changed 10 years ago by Robin Hill <myth@…>

I've attached the log section as requested - this shows it scanning the Test directory and finding the Test1 and Test3 subdirectories, but completely missing the Tést2 subdirectory. The attached application uses the same QT calls to scan the same directory, but lists all three subdirectories. I can only think that some global setting (e.g. locale) is being done elsewhere in the MythTV code which is causing QT to ignore these directories - I can't find any documentation on any applicable QT settings though.

comment:4 Changed 10 years ago by Robin Hill <myth@…>

I've eventually tracked this down to using "su - mythuser" to launch the backend - this was failing to set the LC_ALL and LANG environment variables. Adding these to /etc/environment or launching the backend via "su mythuser" results in the backend successfully scanning all directories. These changes aren't required by the test program I wrote though (it successfully reports all directories in both cases).

comment:5 Changed 10 years ago by Dibblah

Resolution: invalid
Status: newclosed

Thanks for reporting back. If your test program doesn't support locales, it will not exhibit this issue.

Note: See TracTickets for help on using tickets.