Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7494 closed defect (fixed)

Program Guide option "Allow channel jumping in guide" is always true

Reported by: Steven Ellis <support@…> Owned by: Isaac Richards
Priority: minor Milestone: 0.23
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

When this option is disabled you can fast navigate the EPG screen using the buttons 1,4,7,9 on your remote. Under 0.22 it appears that the preference to disable this option is ignored

To reproduce

  • Utilities/Setup?
  • Setup →
  • TV Settings →
  • Program Guide →
    • Next →
      • Disable “Allow channel jumping in guide”
    • Finish →

Then enter the program guide. Pressing any numeric keys will always move you to a channel number.

Change History (7)

comment:1 Changed 10 years ago by Steven Ellis <steven@…>

I think the code relating to this is GuideGrid::keyPressEvent in guidegrid.cpp

I don't understand the logic of this particular section

    // We want to handle jump to channel before everything else
    // The reason is because the number keys could be mapped to
    // other things. If this is the case, then the jump to channel
    // will not work correctly.
    {
        QMutexLocker locker(&m_jumpToChannelLock);

        if (!m_jumpToChannel || m_jumpToChannelEnabled)
        {
            bool isNum;
            event->text().toInt(&isNum);
            if (isNum && !m_jumpToChannel)
            {
                // see if we can find a matching channel before creating the JumpToChannel otherwise
                // JumpToChannel will delete itself in the ctor leading to a segfault
                int i = FindChannel(0, event->text(), false);
                if (i >= 0)
                {
                    m_jumpToChannel = new JumpToChannel(this, event->text(),
                                                        m_currentStartChannel,
                                                        m_currentRow, m_channelCount);
                    updateJumpToChannel();
                }
    
                handled = true;
            }
        }
    
        if (m_jumpToChannel && !handled)
            handled = m_jumpToChannel->ProcessEntry(actions, event);
    }

It appears that m_jumpToChannel will be NULL so numeric key presses will cause a jump to channel even if m_jumpToChannelEnabled=FALSE.

comment:2 Changed 10 years ago by electoys@…

I also agree this bug exists. My version is 0.22. Specifically mythbuntu "branches/release-0-22-fixes (22594)".

P.S. The description should say 1,3,7 & 9 keys.

comment:3 Changed 10 years ago by robertm

Ticket locked: set

comment:4 Changed 10 years ago by Stuart Auchterlonie

Milestone: unknown0.23

comment:5 Changed 10 years ago by paulh

Resolution: fixed
Status: newclosed
Ticket locked: unset
Version: 0.22rc1head

This was fixed in [23175]

comment:6 Changed 10 years ago by electoys

Any chance this changeset could be ported to the 0.22 branch?

comment:7 Changed 10 years ago by stuartm

Ticket locked: set

Use the mailing list please.

Note: See TracTickets for help on using tickets.