Opened 11 years ago

Closed 11 years ago

#7504 closed defect (invalid)

OperationalError: database is locked

Reported by: BobLfoot@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

How to Reproduce

While doing a POST operation on /ticket/7503, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'ea5843bdfc30983f79cd4e35',
 'action': u'leave',
 'author': u'BobLfoot@gmail.com',
 'cnum': u'1',
 'comment': u'MythTv Bug Ticket Web Interface would not let output from SELinux be posted into comment box.  See attached file mythbug_001 for full selinux error found with mythtv.',
 'id': u'7503',
 'replyto': u'',
 'submit': u'Submit changes',
 'ts': u'2009-11-04 21:59:46+00:00'}

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.15) Gecko/2009102918 CentOS/3.0.15-3.el5.centos Firefox/3.0.15

System Information

Trac 0.11.6stable-r8729
Python 2.5.2 (r252:60911, Jan 4 2009, 22:17:10)
[GCC 4.3.2]
setuptools 0.6c8
SQLite 3.5.9
pysqlite 2.4.1
Genshi 0.5.1
mod_wsgi 2.5
Pygments 0.10
Subversion 1.5.1 (r32289)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8729-py2.5.egg/trac/web/main.py", line 445, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8729-py2.5.egg/trac/web/main.py", line 206, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8729-py2.5.egg/trac/ticket/web_ui.py", line 182, in process_request
    return self._process_ticket_request(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8729-py2.5.egg/trac/ticket/web_ui.py", line 504, in _process_ticket_request
    valid = self._validate_ticket(req, ticket) and not problems
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8729-py2.5.egg/trac/ticket/web_ui.py", line 977, in _validate_ticket
    for field, message in manipulator.validate_ticket(req, ticket):
  File "/usr/lib/python2.5/site-packages/TracSpamFilter-0.2.1dev_r6990-py2.5.egg/tracspamfilter/adapters.py", line 67, in validate_ticket
    FilterSystem(self.env).test(req, author, changes)
  File "/usr/lib/python2.5/site-packages/TracSpamFilter-0.2.1dev_r6990-py2.5.egg/tracspamfilter/api.py", line 133, in test
    score, ['%s (%d): %s' % r for r in reasons]).insert()
  File "/usr/lib/python2.5/site-packages/TracSpamFilter-0.2.1dev_r6990-py2.5.egg/tracspamfilter/model.py", line 141, in insert
    db.commit()
OperationalError: database is locked

Attachments (1)

Screenshot.png (110.0 KB) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by anonymous

Attachment: Screenshot.png added

comment:1 Changed 11 years ago by paulh

Resolution: invalid
Status: newclosed

Not a myth bug. There was some problems with the server due to high demand which have mostly been fixed.

Note: See TracTickets for help on using tickets.