Modify

Opened 8 years ago

Closed 7 years ago

#7522 closed defect (fixed)

choppy playback on new danish dvb channels

Reported by: martin.rene.mortensen@… Owned by: janne
Priority: minor Milestone: 0.23
Component: MythTV - Video Playback Version: 0.22-fixes
Severity: medium Keywords: h.264 hdtv
Cc: Ticket locked: yes

Description

Danish broadcasting closed down the analog signal and started 3 new channels with HDTV signals. I can't play these new HDTV streams without extreme jerking of the whole image - in seemingly backward and forward motion. I am running Ubuntu 9.04 64-bit, MythTV trunk 22760M, CPU is Ahtlon 64 x2 4400. I was running XV, but now switched to VDPAU (8400GS, 256MB) and its the same. I tried following patch: http://svn.mythtv.org/trac/attachment/ticket/7252/mythtv_decoder_reorder_pts_v3.diff

and setting VDPAU buffers to 40 according to info in http://svn.mythtv.org/trac/ticket/7405

  • but no luck.

Originally from the MythTV users list: http://www.gossamer-threads.com/lists/mythtv/users/406054

Attachments (4)

ticket7522.log (282.4 KB) - added by jakob@… 8 years ago.
mythfrontend -v playback,file,network
mythfrontend.log.zip (47.7 KB) - added by Martin R Mortensen <martin.rene.mortensen@…> 8 years ago.
-v playback,file,network
mythtv_h264_strict_test1.diff (679 bytes) - added by tralph11@… 8 years ago.
proposed test patch by cehoyos at FFmpeg
mythtv_ffmpeg_r20504.diff (2.1 KB) - added by tralph11@… 8 years ago.
official solution from FFmpeg r20504 by michael

Download all attachments as: .zip

Change History (20)

comment:1 follow-up: Changed 8 years ago by Dibblah

  • Status changed from new to infoneeded_new

Logs from -v playback,file,network

please.

Changed 8 years ago by jakob@…

mythfrontend -v playback,file,network

comment:2 Changed 8 years ago by jakob@…

I have the exact same problem. It is not limited to the HD channel, but to most of the new h.264 channels. I have attached a log output for my configuration (it might differ from the original ticket creator). A sample file is available here

Additional info: mplayer produces similar error messages and behaves exactly like MythTV. VLC plays file perfectly. ffplay (svn trunk) behaves like Mythtv ffplay -strict plays file perfectly

Configuration: Athlon XP 2400+, Nvidia 5200FX, Ubuntu 9.10, mythtv-0.22-fixes

Changed 8 years ago by Martin R Mortensen <martin.rene.mortensen@…>

-v playback,file,network

comment:3 Changed 8 years ago by mofo@…

I have the exact same problem. I had problems with all new h.264 channels in DK but after ver. 22722 some of the channels (DR K and DR Ramsjang) started working. Let me know if I need to post some example video

/mofo

comment:4 in reply to: ↑ 1 Changed 8 years ago by anonymous

same problem here... If needed I'll post some log files as well.

/T2

comment:5 Changed 8 years ago by Martin R Mortensen <martin.rene.mortensen@…>

It is true, that DR K and DR Ramasjang work fine now - at least most shows. DR HD is still bad. I am not sure if they changed the format on 2 channels - they are not really HD channels, but EPG says the shows are in HD.

I don't think MythTV changed - but I guess its easily tested. I will check when I get the chance.

comment:6 Changed 8 years ago by anonymous

Same problem here with MythBuntu? 9.10 plain install, mythtv ver 0.22.0+fixes22594-0ubuntu1

Don't know if this is made clear, but the new channels are mpeg4 h264 channels in dvb-t with aac audio, most channels are 720x576 and one 1280x720 pixels.

comment:7 Changed 8 years ago by tralph11@…

Please move discussion to the mailing lists. A thread already exists on -users.

This problem has already been reported to the mplayer and FFmpeg developers and some patches are already available that fix the problem. Please reference

Bug reports

http://roundup.ffmpeg.org/roundup/ffmpeg/issue1523

http://thread.gmane.org/gmane.comp.video.mplayer.user/61613

FFmpeg discussion (with patches)

http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2009-November/078153.html

http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2009-November/078207.html

Changed 8 years ago by tralph11@…

proposed test patch by cehoyos at FFmpeg

comment:8 Changed 8 years ago by Martin R Mortensen <martin.rene.mortensen@…>

The attached patch works. flawless H264 HDTV now - I can play the old recordings as well. Fantastic.

Changed 8 years ago by tralph11@…

official solution from FFmpeg r20504 by michael

comment:9 Changed 8 years ago by cthulhu@…

The latest patch (mythtv_ffmpeg_r20504.diff) fixes this issue for me as well. Could this please be commited, so we danes aren't forced to patch every new version.

Thanks in advance and thanks for the patch.

comment:10 Changed 8 years ago by anonymous

I can confirm that the last patch works on arch and ubuntu. Please commit to 0.22-fixes.

Tanks

Jesper

comment:11 Changed 8 years ago by anonymous

Please have a look at Ticket #7481. There is also a (simpler?) patch that worked for me. Maybe this is a similiar Problem. Also Ticket 6922 seems to be similar.

comment:12 Changed 8 years ago by byronmyth

Any reason why this hasn't been commited yet?

comment:13 Changed 8 years ago by Dibblah

  • Status changed from infoneeded_new to new
  • Ticket locked set

comment:14 Changed 7 years ago by janne

  • Milestone changed from unknown to 0.23
  • Status changed from new to accepted
  • Version changed from unknown to 0.22-fixes

will be fixed by ffmpeg sync

comment:15 Changed 7 years ago by janne

(In [23515]) libavcodec: backport ffmpeg changeset 20504 to fix h264 decoding, Refs #7522

comment:16 Changed 7 years ago by tralph

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in trunk with recent ffmpeg sync and in 0.22-fixes with commit [23515].

Add Comment

Modify Ticket

Action
as closed The owner will remain janne.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.