Opened 10 years ago

Closed 9 years ago

#7526 closed defect (fixed)

Cannot change recording name from UI

Reported by: david.hagood@… Owned by: stuartm
Priority: minor Milestone: 0.24
Component: MythTV - General Version: 0.22
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have several recovered programs that have names like "1082_20080101022" - I want rename that to program title "Nova" and episode title "UnderDogs?", but I cannot change the name.

Steps to reproduce: Launch Myth Front end. Media library -> Watch Recordings Select one of the recovered programs. I (information menu) Recording options->Change recording title Enter new data Select OK

Expected results: Program data changed. Recording shows up under new name. Selecting recording and displaying recording information shows new title

Actual results: Recording title unchanged.

Repeatability: Every time.

Change History (7)

comment:1 Changed 10 years ago by stuartm

Status: newinfoneeded_new

I cannot reproduce this at all. To be clear, the recording _title_ doesn't change or it doesn't move to a _group_ for this title? The former definitely works, the later won't since the logic just isn't there to make that change, you would need to exit and re-enter the screen.

comment:2 Changed 10 years ago by david.hagood@…

The recording title does not change.

This is with a recording that was recovered with the myth.rebuilddatabase.pl script - so the issue may be one of the database not having all the entries needed.

I can change entries that were recorded by the back-end and thus have full database entries - the problem is ONLY on recovered items.

Try copying a recorded file to a new name, importing that via the rebuilddatabase script, then renaming that file.

comment:3 Changed 10 years ago by bornskeptical@…

I've got the same issue with files recovered with myth.rebuilddatabase.pl - the recovered files were origionally recorded by mythtv and I just used the defaults when running myth.rebuilddatabase.pl

I can change the name / subtitle of other programs recorded by mythtv without any problems.

comment:4 Changed 10 years ago by robertm

Status: infoneeded_newnew

comment:5 Changed 9 years ago by robertm

Owner: changed from Isaac Richards to stuartm
Status: newassigned

comment:6 Changed 9 years ago by stuartm

Milestone: unknown0.24
Status: assignedaccepted
Last edited 9 years ago by stuartm (previous) (diff)

comment:7 Changed 9 years ago by stuartm

Resolution: fixed
Status: acceptedclosed

(In [25720]) Due to some fault logic changes made in the PBB metadata editor weren't saved the recording being edited was in a group by the same name (title grouping), this should fix that. Probably fixes #7526

Note: See TracTickets for help on using tickets.