Opened 10 years ago

Closed 10 years ago

#7545 closed defect (invalid)

viewable portion of overscan display and UI edges

Reported by: brian@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.22
Severity: medium Keywords:
Cc: Ticket locked: no

Description

On good-old CRT TVs, with overscan, it seems impossible to adjust the UI so that it's entirely visible within the viewable portion of the screen (i.e. inside the overscan area) and have crisp edges.

This is because unlike a normal TV signal which has a picture that is knowingly broadcasted larger than the viewable area (and allowances are made for that) the myth UI tries to make it's picture _exactly_ the same size as the viewable area.

The problem is that on CRT TVs, this area where the overscan starts is never crisp and sharp.

See the image I have attached for an example. Notice the "wow" in the top left side of the UI border.

This can be solved by making the UI window stretch larger than the viewable area, into the overscan borderd, but allowing the adjustments being made to keep the UI inside the viewable area by placing the widgets on the canvas tighter together rather than making the whole canvas simply smaller.

Attachments (1)

P1010451.JPG (96.5 KB) - added by brian@… 10 years ago.
picture of overscan sloppiness

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by brian@…

Attachment: P1010451.JPG added

picture of overscan sloppiness

comment:1 Changed 10 years ago by Dibblah

Resolution: invalid
Status: newclosed

Currently, the UI does not support this option. If you are able to work on it and provide a patch, please comment on this ticket and it will be reopened.

Please add feature requests to the relevant wiki page or discuss them in the mailing lists.

Note: See TracTickets for help on using tickets.