Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7551 closed defect (invalid)

Page Up/Down does not wrap when wrap style set to items

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: low Keywords:
Cc: Ticket locked: yes

Description

I am seeing this in MythVideo? with the Mythbuntu theme from trunk r22791.

The horizontal list which is themed with the "items" wrap style wraps with left/right. However, Page Up/Down? does not wrap. If you're at position 0 and hit Page Up, the index does not change. If you're at position 2, it goes to position 0. The behavior is mirrored at the bottom of the list with Page Down. I also confirmed the same behavior in the watch recordings vertical list.

This behavior seems inconsistent. I would expect paging to wrap the same as single increments.

Change History (3)

comment:1 Changed 10 years ago by stuartm

Resolution: invalid
Status: newclosed

Scrolling behaviour is handled by <scrollstyle> and is unconnected to <wrapstyle>

comment:2 Changed 10 years ago by anonymous

I was obviously wrong about wrapstyle vs. scrollstyle. That does not change the fact that the behavior seen is quirky or inconsistent.

If the behavior is as designed, fine close the bug and state so. If it is incorrect, would not changing the bug description to be accurate be a better reaction?

comment:3 Changed 10 years ago by stuartm

Ticket locked: set

By design Page Up/Page? Down don't wrap, this was the preferred behaviour when it was discussed since it enables finding the start/end of the list.

Note: See TracTickets for help on using tickets.