Opened 14 years ago

Closed 13 years ago

#757 closed patch (duplicate)

Translate IR keypresses directly to actions

Reported by: mythtv@… Owned by: stuartm
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Currently, IR symbols are translated by LIRC to IR key presses, which MythTV translates to character key presses, which are then translated to actions.

This patch removes one of these steps. It converts IR key presses directly into actions. It does this internally by mapping them to pseudo key numbers. Externally, IR keys are called "remoteFoo", where Foo is the description of the key in lircd.conf.

What are the advantages? 1) simplified configuration: .mythtv/lircrc not required (although it's the only place that repeat and delay commands can currently be specified) 2) easier configuration: user can think in terms of IR keys instead of having to remember IR key => key mapping 3) increased flexibility: IR keys can map arbitrary to actions without affecting keyboard mappings, IR keys on different remotes can easily map to different actions (if they have different names)

Disadvantages: Although the initial setup get a user basic functionality: arrow keys, enter, etc., this is not always the case due to different names on different remotes. When this happens, the current interface, even with mythcontrols, not great.

This change is compatible with old systems. Any IR key presses not understood are reconsidered as the key to which they correspond in lircrc.

Attachments (1)

remotekey.patch (18.9 KB) - added by mythtv@… 14 years ago.
proposed patch

Download all attachments as: .zip

Change History (7)

Changed 14 years ago by mythtv@…

Attachment: remotekey.patch added

proposed patch

comment:1 Changed 14 years ago by Isaac Richards

Not sure I like the addition of the 'remoteBlah' to all the keybindings.

comment:2 Changed 14 years ago by etnoy at broach dot se

This patch is really something that has been on my wishlist. It would also be cool if one could have one "global" config and several independent configs for different parts of myth. For example, let one button do something in TV mode and something else in the weather browser mode.

comment:3 Changed 14 years ago by danielk

Milestone: 0.20
Version: head

comment:4 Changed 13 years ago by cpinkham

Milestone: 0.20unknown

comment:5 Changed 13 years ago by stuartm

Milestone: unknown0.21
Owner: changed from Isaac Richards to stuartm

comment:6 Changed 13 years ago by stuartm

Resolution: duplicate
Status: newclosed

Duplicate of #2239

Note: See TracTickets for help on using tickets.