Opened 10 years ago

Closed 10 years ago

#7573 closed defect (invalid)

mythmainwindow_internal.h:10:21: error: QGLWidget: No such file or directory

Reported by: caseybragg@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: Packaging Version: 0.22
Severity: medium Keywords: QGLWidget
Cc: Ticket locked: no

Description

I'm trying to compile mythtv-release-0.22-fixes pm a Debian box. I'm running into the following error.

See below: mythmainwindow_internal.h:10:21: error: QGLWidget: No such file or directory

I have qt4.4 installed. Mythtv 0.21 ran correctly. I'm having the same issue trying to compile either fixes or trunk or the current "stable" release available on the wiki. I used no configure flags. I simply ran "configure" and then "make" with no flags.

make[2]: Leaving directory `/mnt1/mythtv-release-0.22-fixes/mythtv/libs/libmythnvctrl'
cd libmythui/ && make -f Makefile
make[2]: Entering directory `/mnt1/mythtv-release-0.22-fixes/mythtv/libs/libmythui'
g++ -c -pipe -march=pentiumpro -fomit-frame-pointer -O3 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -D__STDC_CONSTANT_MACROS -I/usr/include/kde/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/directfb -D_REENTRANT -D_REENTRANT -DPIC -fPIC -DMMX -Di386 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DUSING_VDPAU -DUSING_X11 -DUSE_JOYSTICK_MENU -DUSE_LIRC -DUSING_XRANDR -DUSE_OPENGL_PAINTER -DUSING_QTWEBKIT -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtWebKit -I/usr/include/qt4/QtWebKit -I/usr/include/qt4 -I/usr/include -I/usr/local -I../libmythdb -I../.. -I.. -I/usr/X11R6/include -I. -I. -o mythmainwindow.o mythmainwindow.cpp
In file included from mythmainwindow.cpp:3:
mythmainwindow_internal.h:10:21: error: QGLWidget: No such file or directory
In file included from mythmainwindow.cpp:3:
mythmainwindow_internal.h:13: error: expected class-name before ‘{’ token
mythmainwindow_internal.h:29: error: expected class-name before ‘{’ token
mythmainwindow.cpp: In constructor ‘MythPainterWindowGL::MythPainterWindowGL(MythMainWindow*, MythMainWindowPrivate*)’:
mythmainwindow.cpp:253: error: class ‘MythPainterWindowGL’ does not have any field named ‘QGLWidget’
mythmainwindow.cpp:256: error: ‘setAutoBufferSwap’ was not declared in this scope
mythmainwindow.cpp: In constructor ‘MythPainterWindowVDPAU::MythPainterWindowVDPAU(MythMainWindow*, MythMainWindowPrivate*)’:
mythmainwindow.cpp:269: error: class ‘MythPainterWindowVDPAU’ does not have any field named ‘QGLWidget’
mythmainwindow.cpp:272: error: ‘setAutoBufferSwap’ was not declared in this scope
mythmainwindow.cpp: In member function ‘void MythMainWindow::Init()’:
mythmainwindow.cpp:866: error: cannot convert ‘MythPainterWindowGL*’ to ‘QWidget*’ in assignment
mythmainwindow.cpp:875: error: cannot convert ‘MythPainterWindowVDPAU*’ to ‘QWidget*’ in assignment
mythmainwindow.cpp: In member function ‘virtual bool MythMainWindow::eventFilter(QObject*, QEvent*)’:
mythmainwindow.cpp:1517: warning: unused variable ‘clicked’
make[2]: *** [mythmainwindow.o] Error 1
make[2]: Leaving directory `/mnt1/mythtv-release-0.22-fixes/mythtv/libs/libmythui'
make[1]: *** [sub-libmythui-make_default] Error 2
make[1]: Leaving directory `/mnt1/mythtv-release-0.22-fixes/mythtv/libs'
make: *** [sub-libs-make_default-ordered] Error 2

Change History (4)

comment:1 Changed 10 years ago by caseybragg@…

One more thing - I'm using the NVIDIA installer 190.42 if that matters.

comment:2 Changed 10 years ago by sphery

Status: newinfoneeded_new

Are you sure you have all of the required Qt dependencies installed? This looks suspiciously like a missing Qt OpenGL package. Something like, libqt4-opengl-dev , perhaps.

comment:3 Changed 10 years ago by caseybragg@…

Outstanding. Installing libqt4-opengl-dev got be rolling again. Great insight! Thanks! This ticket can be closed.

comment:4 Changed 10 years ago by Dibblah

Resolution: invalid
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.