Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7589 closed patch (fixed)

LCD is not cleared after finishing watching a recording

Reported by: amb@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After exiting a recording the LCD screen is not reset and will remain displaying the status of the recording.

Patch attached

Attachments (2)

tv_play.cpp.diff (357 bytes) - added by amb@… 10 years ago.
Patch for tv_play.cpp
7589.diff (1.5 KB) - added by paulh 10 years ago.
Better handling of show time and show recording status

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by amb@…

Attachment: tv_play.cpp.diff added

Patch for tv_play.cpp

comment:1 Changed 10 years ago by paulh

Resolution: worksforme
Status: newclosed
Version: 0.22head

Can't reproduce this in trunk. The TV destructor already calls LCD::switchToTime() so don't see what your patch does that we don't already do.

comment:2 Changed 10 years ago by amb@…

I have checked the configuration of my MythTV setup and I think that the difference is that I have disabled the time display in the LCD. Under the settings -> appearance -> LCD device display configuration screen I have disabled the "display time" and "display menus" options. Switching to the non-existent time display will not cause the current display to be removed.

Changed 10 years ago by paulh

Attachment: 7589.diff added

Better handling of show time and show recording status

comment:3 Changed 10 years ago by paulh

Resolution: worksforme
Status: closednew

I guess no one envisioned someone would want to turn the time display off because all of Myth uses that as a default if there is nothing else to show. While your patch will fix the problem after exiting playback there are other places where it is also broken.

Can you please test the attached patch. It should always clear the lcd if switchToTime() is called and show time is off and it should also handle having show recording status on and show time off properly.

comment:4 Changed 10 years ago by paulh

Resolution: fixed
Status: newclosed

(In [23256]) Fixes a problem where the lcd wasn't being cleared as it should if the show time setting was turned off. Should also work better for all combinations of show time and show recording status better. Fixes #7589.

Not tested every possible combination of LCD settings so if you spot any problems let me know and I will fix it.

comment:5 in reply to:  3 Changed 10 years ago by amb@…

Replying to paulh:

Can you please test the attached patch. It should always clear the lcd if switchToTime() is called and show time is off and it should also handle having show recording status on and show time off properly.

I have been running the patch for a couple of days now and it seems to work the same as the original patch that I included.

Note: See TracTickets for help on using tickets.