Opened 10 years ago

Closed 9 years ago

#7591 closed defect (fixed)

mythvideo 0.22 dvd playback memory leak

Reported by: mattsch@… Owned by: skamithi
Priority: minor Milestone: unknown
Component: MythTV - DVD Playback Version: 0.22
Severity: high Keywords:
Cc: Ticket locked: no

Description

mythvideo plays a dvd but continuously eats system memory until it runs out and then mythfrontend crashes. This appears to be the case with both the internal player and mplayer when playing a dvd within mythfrontend. If I were to play a dvd in mplayer outside mythfrontend, memory usage is normal. I can reproduce this on amd64 and x86 on mythvideo 0.22-r22807. I have tested in gentoo and minimyth. Both exhibit the problem.

Change History (4)

comment:1 Changed 10 years ago by skamithi

Priority: criticalminor

comment:2 Changed 9 years ago by robertm

Status: newinfoneeded_new

Need a valgrind log of the leak. Could possibly be fixed with a dvdnav/read resync, depending on what the leak is.

comment:3 Changed 9 years ago by robertm

libdvdnav/read now resynced, need any valgrind log to be with trunk >= r25514

comment:4 Changed 9 years ago by robertm

Resolution: fixed
Status: infoneeded_newclosed

No response, unable to reproduce. Possibly fixed in resync.

Note: See TracTickets for help on using tickets.