Opened 11 years ago

Closed 11 years ago

#7594 closed defect (duplicate)

osd.cpp:1721: error: invalid use of undefined type 'struct QHash<QString, QString>'

Reported by: Axel.Thimm@… Owned by: Isaac Richards
Priority: minor Milestone: 0.23
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Building on RHEL5 against qt 4.4.3 fails with

g++ -c -m64 -pipe -march=k8 -fomit-frame-pointer -O3 -I/usr/include/nvidia-graphics -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -D__STDC_CONSTANT_MACROS -I/usr/include/freetype2 -D_REENTRANT -DPIC -fPIC -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DUSING_X11 -DUSING_XV -DUSING_XVMC -DUSING_XVMCW -DUSING_XVMC_VLD -DUSING_VDPAU -DUSING_OPENGL -DUSING_OPENGL_VSYNC -DUSING_OPENGL_VIDEO -DUSING_MHEG -DUSING_FRONTEND -DUSING_FFMPEG_THREADS -DUSING_ALSA -DUSING_OSS -DUSING_V4L -DUSING_LINUX_FIREWIRE -DUSING_FIREWIRE -DUSING_LIBAVC_5_3 -DUSING_IPTV -DUSING_HDHOMERUN -DUSING_IVTV -DUSING_HDPVR -DUSING_DVB -DUSING_BACKEND -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib64/qt44/mkspecs/linux-g++-64 -I. -I/usr/lib64/qt44/include/QtCore -I/usr/lib64/qt44/include/QtCore -I/usr/lib64/qt44/include/QtNetwork -I/usr/lib64/qt44/include/QtNetwork -I/usr/lib64/qt44/include/QtGui -I/usr/lib64/qt44/include/QtGui -I/usr/lib64/qt44/include/QtXml -I/usr/lib64/qt44/include/QtXml -I/usr/lib64/qt44/include/QtSql -I/usr/lib64/qt44/include/QtSql -I/usr/lib64/qt44/include -I/usr -I.. -I../.. -I. -I../libmyth -I../libavcodec -I../libavformat -I../libavutil -I../libswscale -I../libmythmpeg2 -I../libmythdb -I../libmythhdhomerun -I../libmythdvdnav -Idvbdev -Impeg -Iiptv -Ichannelscan -I../libmythlivemedia/BasicUsageEnvironment/include -I../libmythlivemedia/BasicUsageEnvironment -I../libmythlivemedia/groupsock/include -I../libmythlivemedia/groupsock -I../libmythlivemedia/liveMedia/include -I../libmythlivemedia/liveMedia -I../libmythlivemedia/UsageEnvironment/include -I../libmythlivemedia/UsageEnvironment -I../libmythdb -I../libmythui -I/usr/include -I/usr/X11R6/include -I. -I. -o osd.o osd.cpp
osd.cpp: In member function 'void OSD::SetText(const QString&, InfoMap&, int)':
osd.cpp:1721: error: invalid use of undefined type 'struct QHash<QString, QString>'
/usr/lib64/qt44/include/QtCore/qdatastream.h:61: error: declaration of 'struct QHash<QString, QString>'
osd.cpp:1721: error: invalid use of undefined type 'struct QHash<QString, QString>'
/usr/lib64/qt44/include/QtCore/qdatastream.h:61: error: declaration of 'struct QHash<QString, QString>'
osd.cpp:1723: error: no match for 'operator[]' in 'infoMap["chanid"]'
osd.cpp:1726: error: no match for 'operator[]' in 'infoMap["iconpath"]'
osd.cpp:1743: error: invalid use of undefined type 'struct QHash<QString, QString>'
/usr/lib64/qt44/include/QtCore/qdatastream.h:61: error: declaration of 'struct QHash<QString, QString>'
osd.cpp:1743: error: no match for 'operator[]' in 'infoMap["iconpath"]'
osd.cpp:1744: error: no match for 'operator[]' in 'infoMap["iconpath"]'
osd.cpp:1752: error: invalid use of undefined type 'struct QHash<QString, QString>'
/usr/lib64/qt44/include/QtCore/qdatastream.h:61: error: declaration of 'struct QHash<QString, QString>'
osd.cpp:1752: error: no match for 'operator[]' in 'infoMap["coverartpath"]'
osd.cpp:1753: error: no match for 'operator[]' in 'infoMap["coverartpath"]'
osd.cpp: In member function 'void OSD::SetInfoText(InfoMap, int)':
osd.cpp:1763: error: 'infoMap' has incomplete type
/usr/lib64/qt44/include/QtCore/qdatastream.h:61: error: declaration of 'struct InfoMap'
make[2]: *** [osd.o] Error 1

This against r22849. r22749 was stull building OK. The version of qt (4.4.3) build successfully on Fedora 10, so it looks like an issue with g++?

Change History (4)

comment:1 Changed 11 years ago by Jonathan Martens <jonathan@…>

Axel, [22749] is an extensive rework of include files. Can you build [22748] on RHEL5 to see if that might be the cause of the error?

comment:2 in reply to:  1 Changed 11 years ago by Jonathan Martens <jonathan@…>

Replying to Jonathan Martens <jonathan@…>:

Axel, [22749] is an extensive rework of include files. Can you build [22748] on RHEL5 to see if that might be the cause of the error?

Oops... that should have read:

Axel, [22849] is an extensive rework of include files. Can you build [22848] on RHEL5 to see if that might be the cause of the error?

comment:3 Changed 11 years ago by Jonathan Martens <jonathan@…>

It seems Debian 5 is also suffering from the same according to #7593.

comment:4 Changed 11 years ago by stuartm

Resolution: duplicate
Status: newclosed

Duplicate of #7593

Note: See TracTickets for help on using tickets.