Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7595 closed defect (fixed)

MythArchive DVD creation. Sound lost after single wrong audio frame size.

Reported by: J.Pilk@… Owned by: paulh
Priority: minor Milestone: unknown
Component: Plugin - MythArchive Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Please see http://www.gossamer-threads.com/lists/mythtv/users/404383

I'm attaching another set of snippets from mythburn.log

The DVD creation completes but the result isn't usable. Since going to 0.22 this has become a real problem. I'm preprocessing with mencoder, which also had a recent update, but I don't know where the critical change lies.

The original recording and the demuxed stream0.mp2 file play with only momentary glitches. Cutting out about 3 seconds using edit mode can give a good DVD but is cumbersome.

Attachments (1)

mytharchticket.txt (4.0 KB) - added by anonymous 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by anonymous

Attachment: mytharchticket.txt added

comment:1 Changed 10 years ago by J.Pilk@…

I've now got around to installing ProjectX and it seems to be working with my (slightly hacked) version of mythburn.py. It typically (on a small sample so far) says it has corrected a few errors, some of which are very near the end of the mythtranscoded recordings and wouldn't really have affected the playability of the DVD. I'll see how it goes.

comment:2 Changed 10 years ago by J.Pilk@…

Sorry, but ProjectX isn't the magic solution. I've just used it to create a DVD with 3 input recordings which all played well. On the DVD image two lose sound prematurely. For these the mythburn.log 'summary of created media files' shows that the Audio file is much shorter that the Video. Maybe I can use this to give an early warning of the problem - instead of waiting for the entire process to complete - but the failure rate I am seeing now is very much higher than it was in 0.21, without ProjectX, and with several hundred disks in my archive/unstructured collection.

comment:3 Changed 10 years ago by paulh

Component: MythTV - GeneralPlugin - MythArchive
Owner: changed from Isaac Richards to paulh

Not much has changed in MythArchive? for a long time so no idea why 0.22 should be any different than 0.21.

I no longer use MythArchive? to create DVD's so fixing any bugs especially ones that I can't reproduce are very low on my todo list.

comment:4 Changed 10 years ago by J.Pilk@…

I don't think the problem lies in the MythArchive? code; it's in the demuxer. That code hasn't changed recently, either, but something along the line seems to have made it less robust. I'm making slow progress in adapting posted scripts using ProjectX to do what I want before entering MythArchive?, so that any problems with a recording can be found earlier and perhaps corrected, but as yet this isn't well integrated into Myth. Have you stopped making DVDs, or do you use another tool to do it?

comment:5 Changed 10 years ago by J.Pilk@…

An update. I'm now using ProjectX on my raw DVB-T recordings to select the main audio stream and apply the cutlist - ie, as a replacement for mythtranscode - before entering MythArchive?, and I no longer see this problem. Occasionally a few frames are dropped - and usually some 'useless B-frames' at edit points - but the process seems robust. It looks as if my report above of data loss with ProjectX arose because I used to pre-process all recordings with mencoder. I've seen earlier recommendations to avoid pre-processing before ProjectX and my experience supports this.

comment:6 Changed 10 years ago by robertm

Resolution: fixed
Status: newclosed

Reporter appears satisfied with using ProjectX (and issues like this were a motivator in adding it as an option in the first place), closing.

comment:7 Changed 10 years ago by J.Pilk@…

My script using Project-X is at ticket #8347 and a related patch for Mythburn.py is at #8376. Parts of this - enabling use of M2VRequantiser - have been committed at r24416

Note: See TracTickets for help on using tickets.