Opened 10 years ago

Closed 9 years ago

#7599 closed defect (fixed)

MythWeb - Odd Extension To Directly Downloaded Files

Reported by: Mark Garland <mythtvtrac@…> Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: 0.22
Severity: medium Keywords:
Cc: Ticket locked: no

Description

As reported here: http://www.gossamer-threads.com/lists/mythtv/users/408589

In MythWeb, in the Recorded Programmes page, if I select "Direct Download" next to a programme, the filename suggested has an odd extension of ".mpg..mpg" resulting in a filename like "BBC News at Six.mpg..mpg".

It makes little difference as the file can be easily renamed, and in many cases works without renaming.

Seems to have crept in since 0.22 as 0.21 worked fine for me. Confirmed by one other user at the time of writing.

I'm running 0.22.0+fixes22594-0ubuntu1 on Kubuntu Koala 9.10.

Attachments (1)

suffix.patch (1.0 KB) - added by Nijn 10 years ago.
patch

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Nijn

Attachment: suffix.patch added

patch

comment:1 Changed 10 years ago by Rob Smith

Resolution: fixed
Status: newclosed

(In [23677]) Fixes #7599, this removes the double suffix from the raw downloads

comment:2 in reply to:  1 Changed 9 years ago by frank.paulsen@…

Resolution: fixed
Status: closednew

Replying to kormoc:

(In [23677]) Fixes #7599, this removes the double suffix from the raw downloads

this only fixes the problem for requests containing HTTP_RANGE. the second part from suffix.patch was not applied, so the default case is still broken in 0.23.

i am using mythweb 0.23-0.0lenny1 from debian.multimedia.org

comment:3 Changed 9 years ago by Rob Smith

Resolution: fixed
Status: newclosed

(In [25388]) Fixes #7599, this removes the double suffix from the raw downloads

Note: See TracTickets for help on using tickets.