Opened 10 years ago

Closed 10 years ago

#7602 closed defect (wontfix)

Fixes 0.22 - mythflix crashing upon exit

Reported by: caseybragg@… Owned by: kkuphal
Priority: minor Milestone: unknown
Component: Plugin - MythFlix Version: 0.22rc1
Severity: low Keywords:
Cc: Ticket locked: no

Description

I'm having trouble nailing down exactly why this happens. I'll do my best to outline the pattern here.

I'm reporting on Fixes-0.22.

Pattern: 1) I enter MythFlix? 2) Enter View Queue (other MythFlix? functions exhibit this behavior too) 3) See the resulting screen render with my movies in queue 4) Press ESC to go to the previous screen. This problem happens more frequently (as in - not always) if I press ESC within 1 second of the presentation of the rendered screen. 5) I see the previous screen (the one that says "View Queue) for an instant. 6) MythTV crashes with no warning or error message.

Here is what I see in the logs. Mythflix is busy harvesting boxshots from netflix for movies in my queue. I see the following errors at the time of the crash. FYI, I've substituted the ellipses below (...). Note the QSqlQuery and QObject lines.

2009-11-18 11:21:30.947 Using protocol version 50 2009-11-18 11:21:34.855 Loading menu theme from /usr/local/share/mythtv/themes/defaultmenuinfo_menu.xml 2009-11-18 11:21:37.131 Loading window theme from /usr/local/share/mythtv/themes/blootube-wide/menu-ui.xml 2009-11-18 11:21:37.193 Loading menu theme from /usr/local/share/mythtv/netflix_menu.xml 2009-11-18 11:27:02.817 Loading window theme from /usr/local/share/mythtv/themes/blootube-wide/menu-ui.xml 2009-11-18 11:27:02.879 Loading menu theme from /usr/local/share/mythtv/netflix_menu.xml QSqlQuery::value: not positioned on a valid record 2009-11-18 11:27:04.675 Loading window theme from /usr/local/share/mythtv/themes/blootube-wide/netflix-ui.xml 2009-11-18 11:27:04.675 Loading window theme from /usr/local/share/mythtv/themes/default-wide/netflix-ui.xml QObject: Do not delete object, 'unnamed', during its event handler''' 2009-11-18 11:27:06.311 Server returned an error status code 404 for url: http://cdn.nflximg.com/us/boxshots/large//... 2009-11-18 11:27:06.578 Server returned an error status code 404 for url: http://cdn.nflximg.com/us/boxshots/large//...

Change History (1)

comment:1 Changed 10 years ago by robertm

Resolution: wontfix
Status: newclosed

From experiences in other plugins with a similar issue, I can say that the issue is likely a mishandled preview generation/download event. Unfortunately we have dropped MythFlix? from trunk and won't be supporting it going forward (starting in .23, due in ~45 days). I'm closing this wontfix with the note that the easiest way to avoid it would be to give the download time to complete before backing out of the screen. If someone writes a patch to fix the issue in the meantime I would be happy to apply it to -fixes if it attached here.

Note: See TracTickets for help on using tickets.