Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7661 closed defect (invalid)

mythvideo retains host after deleting storage group and behaves like storage group

Reported by: rpollack@… Owned by: xris
Priority: minor Milestone: unknown
Component: Plugin - MythVideo Version: 0.22
Severity: medium Keywords: mythvideo storage group
Cc: Ticket locked: no

Description

If a storage group is created for mythvideo the "host" field is populated in the mysql videometadata table for the location of the video file. If the video storage group is subsequently eliminated through the mythbackend setup, the "host" field remain populated. The problem is this leads to frontends still trying to access the video files as if they are in storage groups (via myth streaming) instead of the location specified in the frontend setup media file directory. Once I manually deleted the "host" field data the frontends were properly able to find the videos.

Change History (2)

comment:1 Changed 10 years ago by robertm

Resolution: invalid
Status: newclosed

Removing a Storage Group does not touch Video metadata (and likely never will). Since you had records pointing at storage groups, the proper way to fix it would have been a rescan. The fact that you were able to remove just the host field and have them play further indicates that your are running Mythbuntu and/or an old copy of Jamu which had a bug which has since been fixed.

Finally, in trunk you can move any file where you want and rescan the videos and the metadata will be reattached, no matter where the file has moved.

comment:2 Changed 10 years ago by robertm

Component: Apps - NuvexportPlugin - MythVideo
Note: See TracTickets for help on using tickets.