Opened 10 years ago

Closed 9 years ago

#7669 closed defect (invalid)

partially defect mpeg4 screenshots

Reported by: Klavs Klavsen <kl@…> Owned by: Isaac Richards
Priority: minor Milestone: 0.24
Component: MythTV - General Version: 0.22
Severity: low Keywords:
Cc: Ticket locked: no

Description

I'm running Mythtv-0.22+fixes (svn20091118) - and have found that when mythtv-backend tries to generate screenshots of the things it has recorded, it generates MANY errors in the backend log, when making screenshots of recordings from DR Ramasjang (MPEG4 stream) and sometimes the screenshots has a lot of artifacts - see this example: http://vsen.dk/files/1004_20091127085900.mpg.100x75x64.png

There's a link to a recording in #7637 from same channel, so this should be same problem.

The errors in the logs are many lines of this: 2009-11-27 22:17:19.449 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:19.451 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:19.781 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:19.786 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:20.097 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:20.098 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:20.389 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:20.390 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:20.749 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:20.755 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:21.348 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:21.363 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:21.691 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period 2009-11-27 22:17:21.693 [h264 @ 0x40e6b478]non-existing SPS 31 referenced in buffering period

p.s. 0.22+fixes is missing in Version - and I can see from SVN that it has been created.

Change History (5)

comment:1 Changed 10 years ago by Stuart Auchterlonie

Milestone: 0.220.24

Bumping open 0.22 milestone tickets to 0.24

comment:2 Changed 10 years ago by robertm

Status: newinfoneeded_new

Still a problem in .23-rc2?

comment:3 Changed 10 years ago by Klavs Klavsen <kl@…>

Can I test 0.23-rc2 on a frontend, without updating my backend (which is 0.22+fixes) ?

I haven't had time to setup my test system - and the current system is heavily used by my wife and kids (not for mpeg4 stream channels though) - so I'd get killed if I messed it up :(

comment:4 Changed 10 years ago by robertm

No, the backend and frontend will need testing with .23-RC2.

comment:5 Changed 9 years ago by robertm

Resolution: invalid
Status: infoneeded_newclosed

No response, please re-open if still an issue with .23-RC3 or current .23-fixes.

Note: See TracTickets for help on using tickets.