Opened 14 years ago

Closed 14 years ago

#767 closed defect (invalid)

No LiveTV audio & Floating point exception when trying to change audio channel

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

SVN 8152 OTC DVB via HD-3000 Analog audio-out Updated from SVN from about a week ago and now have no audio during live tv. Recordings played in 8152 made previous to updating have audio. When I attempted to change audio track during live tv via "+" key, mythfrontend crashed with a floating point exception. I also noted the "Disabling Audio" in the logs as below.

Log is as follows:

2005-12-06 21:28:13.499 Using protocol version 22 2005-12-06 21:28:13.535 TV: Attempting to change from None to WatchingLiveTV 2005-12-06 21:28:13.552 Using protocol version 22 0: start_time: 5859.060 duration: -9223372036854.775 stream: start_time: 65100.668 duration: -9223372036854.775 bitrate=0 kb/s 2005-12-06 21:28:15.695 AFD: Opened codec 0x82a6050, id(MPEG2VIDEO) type(Video) 2005-12-06 21:28:15.695 NVP: Disabling Audio, params(16,-1,-1) 2005-12-06 21:28:16.882 New DB connection, total: 3 2005-12-06 21:28:16.882 Using realtime priority. 2005-12-06 21:28:16.883 TV: Changing from None to WatchingLiveTV 2005-12-06 21:28:17.058 Video timing method: SGI OpenGL 2005-12-06 21:28:19.839 AFD: Opened codec 0x8bc68b0, id(MPEG2VIDEO) type(Video) 2005-12-06 21:28:19.936 AFD: Initializing video at 1920x1088 pixels. 2005-12-06 21:28:21.518 NVP: prebuffering pause 2005-12-06 21:28:22.219 NVP: prebuffering pause 2005-12-06 21:28:22.896 NVP: prebuffering pause Floating point exception

Attachments (3)

log (9.7 KB) - added by tephra@… 14 years ago.
frontend log
mfe_audio.log (47.9 KB) - added by stuart@… 14 years ago.
Frontend log
mbe_audio.log (128.2 KB) - added by stuart@… 14 years ago.
Backend log

Download all attachments as: .zip

Change History (20)

comment:1 Changed 14 years ago by Isaac Richards

Priority: criticalminor
Severity: highmedium

comment:2 Changed 14 years ago by anonymous

Milestone: 0.19
Priority: minorcritical
Severity: mediumhigh
Version: head

comment:3 Changed 14 years ago by Isaac Richards

Priority: criticalminor
Severity: highmedium

comment:4 Changed 14 years ago by anonymous

Owner: changed from Isaac Richards to danielk
Priority: minorcritical
Severity: mediumhigh

Problem commit was 8150 or 8151

comment:5 Changed 14 years ago by anonymous

Priority: criticalminor
Severity: highmedium

Sorry Isaac didn't mean to change your priority/severity settings. Although I can't for the life of me figure out why a bug which kills recording of audio is a minor priority.

comment:6 Changed 14 years ago by Isaac Richards

Read the TicketHowTo. Priority/severity is for _us_ to decide, not people who can't even be bothered to use an email address when reporting tickets.

comment:7 Changed 14 years ago by tephra@…

Same here, my log was in the other ticket. #768!

3 out of 4 recordings from lastnight dont have audio, recordings from a few days ago work fine, recordings from now work fine.

comment:8 Changed 14 years ago by tephra@…

i should add, im using ALSA, SPDIF output + AC3 passthrough

comment:9 Changed 14 years ago by danielk

Resolution: invalid
Status: newclosed

Closing as invalid until I have 3 needed attachments:

  • The backend log of the recording with '-v record,siparser'
  • The frontend log with '-v playback,audio'
  • The backtrace from the floating point exception.

The first will tell me what the audio streams are with all the original info, the second will tell me which audio is being played and how, and the last thing will tell me what line of code causes the crash. Do this with the latest SVN.

Also are you using any special gcc optimization flags?

comment:10 Changed 14 years ago by tephra@…

Resolution: invalid
Status: closedreopened

Hey Daniel,

attached is a frontend log audio+playback, unfortunatley I cant give you a recording log as these are from Monday night.

Are the .mpg's just raw from the card? or are they run through myth first, ie is the audio lost forever on these 3 programs?

cheers dave

Changed 14 years ago by tephra@…

Attachment: log added

frontend log

comment:11 Changed 14 years ago by danielk

Resolution: duplicate
Status: reopenedclosed

Appears to be duplicate of #763.

From the frontend log it looks like no audio was recorded. Without the backend log it is impossible to tell but this was probably the 'audio on private stream' problem fixed in [8151]. So I'm marking this as a duplicate of #763, unless you can reproduce with the current SVN and get me backend logs; or get me a backtrace so I can fix the floating point exception.

Changed 14 years ago by stuart@…

Attachment: mfe_audio.log added

Frontend log

Changed 14 years ago by stuart@…

Attachment: mbe_audio.log added

Backend log

comment:12 Changed 14 years ago by anonymous

Resolution: duplicate
Status: closedreopened

comment:13 Changed 14 years ago by anonymous

Ah, it looks like you are using the hardware_decoder option and your preferred audio, EIT and subtitle language is Afar, but audio is only available in English. We should fallback to allowing some audio and if no streams are available in languages we understand; I'll make this change...

BTW Are you actually using a hardware DVB decoder card? If not, any audio bugs that made you enable this are probably fixed in SVN.

comment:14 Changed 14 years ago by stuart@…

No I'm not using a hardware decoder - I enabled that option a very long time back on advice from a dev and had forgotten all about it! I will disable it

At least having some fallback when the desired language isn't available will avoid future problems. I'm not aware that an option had been added anywhere to change the preferred language - I can't find it where mythtv-setup suggests (Page 3 of TV/General).

I know it can be changed direct in the database but perhaps it would be better to default to English (instead of Afar) and add the option to change in setup. No default language is perfect but I suspect that DVB is not currently being used in the Afar speaking regions of Africa.

comment:15 Changed 14 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [8188]) Fixes #767.

The problem was that the DVBRecorder would completely ignore audio streams if none was found in a preferred language. This fixes this by re-running the stream selection without language preferrences if no audio was found the first time around. Actually, I backported the AutoPID function from the #712 patch, so the diff is a little bigger than it would be otherwise.

comment:16 Changed 14 years ago by tephra@…

Resolution: fixed
Status: closedreopened

hey daniel,

I played the affected mpg in mplayer and I got sound.

Want me to split of 5/10 secs of recording and post a link for you to look at?

I suspect that it was caused by a bad SVN, but it would be nice to be able to play this particular one in mythtv.

Cheers Dave

comment:17 Changed 14 years ago by danielk

Resolution: invalid
Status: reopenedclosed

Can you try the patch attached to #730?

If that doesn't fix it, reopen this ticket with a backtrace.

Note: See TracTickets for help on using tickets.