Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#7672 closed defect (invalid)

Guide not populated with EIT from 2nd card

Reported by: jan@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: unknown
Component: MythTV - EIT Version: 0.22-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

  • My setup has two cards with (partially) the same channels
  • I have assigned the same channum for each of two identical channels
  • Both video sources have been marked for EIT retrieval
  • Channels on both sources are marked for EIT retrieval
  • Cross source EIT has been enabled

But still, only the guide data for the channels of the first card are populated with the EPG data. Those channels that get their data from XMLTV work fine, just not those that get their guide data from EIT only.

Change History (11)

comment:1 Changed 10 years ago by jan@…

Question from Mike on the mailing list: Did you set the channels you want to share EIT data to have identical XMLTV ID's?

No, they don't have an xmltv id, because there is no xmltv source for them. That's why I use EIT for those channels.

comment:2 Changed 10 years ago by jan@…

comment:3 Changed 10 years ago by jan@…

Anyone?

comment:4 Changed 10 years ago by Daniel Sherwood

I think I have the same problem (see #7789) I am happy to submit more logs or database output if anyone can tell me what is needed.

comment:5 Changed 10 years ago by sphery

The use of EIT data as desired by the reporter is currently unsupported (see http://www.gossamer-threads.com/lists/mythtv/dev/426781#426781 ).

I'm leaving the ticket open so stuarta can decide if he wants to close it as a feature request without a patch or change it to a task ticket for either moving DiSEqC data out of videosource (and removing cross-source EIT) and/or extending cross-source EIT to work as the reporter desires.

comment:8 Changed 9 years ago by robertm

Resolution: invalid
Status: newclosed

FRWOP

comment:9 Changed 9 years ago by beirdo

Resolution: invalid
Status: closednew

Reopening this as it really is not a feature request, it is a bug, even if there has been extra stuff added since.

comment:10 Changed 9 years ago by beirdo

Status: newassigned

comment:11 Changed 9 years ago by jan@…

Quoting Gavin: "To me it's not clear if the issue is that EIT isn't being received from the second card, or if it is and your attempts to combine it have not worked out. Those are two separate issues, and will require different debugging efforts, I'm sure."

The EIT is received on both cards, AFAICT. At least it works on both cards for any channels that are only available on one of those cards. It just doesn't work if a channel exists on both cards. In this case the EPG is only filled for the channel on one of those cards. I can't easily test this at the moment, because in the meantime the affected channel's data is provided by my xmltv provider, so I no longer have to rely on EIT. But if necessary for any debugging purposes, I can probably set this up.

comment:12 Changed 9 years ago by sphery

Resolution: invalid
Status: assignedclosed

After clarification on the list ( http://www.gossamer-threads.com/lists/mythtv/dev/447866#447866 and the rest of the thread), we have confirmed that this was a matter of confusion over the purpose of the Cross source EIT setting. When disabled, EIT works for the reporter, and when enabled, the cross-source EIT functionality works as it should.

This setting will be removed after reworking some of the DiSEqC settings (which are in the videosource table and need to be moved to dtv_multiplex). Also, in the settings rewrite, the Cross source EIT setting may be hidden from view for users not using DiSEqC or similar to prevent confusion.

Thanks for reporting back, Jan.

comment:11 Changed 9 years ago by Janne Grunau

(In [25813]) remove "Cross source EIT" setting

it is unneeded since the supported cases can be handled by prefering the current sourceid. This still works on diseqc settings since the current source will not have that channel if it is on a different source.

Setups with multiple channels with the same networkid, transportid, serviceid triple might "break" since a different channel gets the program data now. This is unsupported and it was pure luck that it "worked" before. Refs #7672

Note: See TracTickets for help on using tickets.