Opened 11 years ago

Closed 10 years ago

#7676 closed defect (fixed)

Switching between DVB-S and DVB-T

Reported by: jode Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

Hey,

I have to say I really like MythTv? 0.22. The new UI addition in particular is quite nice. I have one last issue I've been unable to get to the bottom of and it really has me stumped.

I'm using a HVR-4000 card to receive DVB-T signals and DVB-S signals. My first problem was trying to get DVB-S tuning working. In order to get this working I had to use updated card firmware as detailed here:

http://www.linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-4000#Firmware

Secondly I couldn't get a DVB-T signal so I had to patch the v4l-dvb drivers.

I have both this inputs set up in MythTv?. They are set up in the same input group because DVB-T and DVB-S can not be used simulataneously on the HVR-4000. I also have 'Open card on demand' checked for both inputs.

The first problem is that the EIT for DVB-T is not working. EIT for DVB-S is working fine. I used MythTV to scan for both sets of channels just providing the transponders.

The second and more serious issue is that let's say I start watching a DVB-S station, switch to a DVB-T station then it all works wonderfully. If I then try to switch back to DVB-S again the frontend just hangs.

I've confirmed this configuration to work with with Myth 0.21.

Anyone any clues. I'm aware that this might be another issue with the card. Is there anyway to confirm this from the attached logs.

Attachments (1)

errorlogs.zip (10.5 KB) - added by anonymous 11 years ago.
error logs

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by anonymous

Attachment: errorlogs.zip added

error logs

comment:1 Changed 11 years ago by jode

Version is:

mythbackend version: branches/release-0-22-fixes [22864]

comment:2 Changed 10 years ago by freexe@…

I have a similar issue:

I have myth-backend 0.22 with two tuners in a dvb-s2 (tbs-8920) and dvb-t (nova-t). I'm in the UK and have all the channels setup.

Some of my channels are available on the dvb-s card and some on the dvb-t card, if I change to a channel on the other card it fails to retune to the new channel and dumps me back to the welcome screen.

I can switch input first before changing channels, that works fine.

comment:3 Changed 10 years ago by Jode

Hey,

Do you have any issues with getting the EIT on the Nova-T? Is it just the switching issue you're seeing.

JB.

comment:4 Changed 10 years ago by freexe@…

I think I found my problem, but haven't had a chance to test it fully. I was using the same video source for both the cards and that seems to have been causing lots of the issues. I wasn't aware you couldn't use the same video source but found a forum post saying that myth gets confused to which card to tune if you don't (bug?).

I am getting EIT data fine although I was having some issues around when 0.22 came out but discovered it was because of the digital switchover going on in the UK. There seemed to be sub-channels getting the EIT data.

comment:5 in reply to:  4 Changed 10 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

Replying to freexe@…:

I wasn't aware you couldn't use the same video source but found a forum post saying that myth gets confused to which card to tune if you don't (bug?).

You can't share video sources across inputs when the different inputs are receiving channels via different transmission schemes (e.g. analog vs DVB-T vs DVB-S vs ATSC).

A video source may contain only channels (and their associated tuning information) that are broadcast using a common transmission technique and that can be tuned to by a particular type of tuner. Having DVB-T channels associated with a DVB-S tuner makes no sense. You need a DVB-T video source for your DVB-T, and a separate DVB-S video source for your DVB-S tuner.

If you have any more queries regarding this, please follow up on the mythtv-users list.

comment:6 in reply to:  4 Changed 10 years ago by anonymous

Replying to freexe@…:

I think I found my problem, but haven't had a chance to test it fully. I was using the same video source for both the cards and that seems to have been causing lots of the issues. I wasn't aware you couldn't use the same video source but found a forum post saying that myth gets confused to which card to tune if you don't (bug?).

I am getting EIT data fine although I was having some issues around when 0.22 came out but discovered it was because of the digital switchover going on in the UK. There seemed to be sub-channels getting the EIT data.

How have you got on with this? I have just taken delivery of the same S2 card, with the intention of replacing my 2 Nova T500's to get HD, I now realise I will lose some channels if I do this. I dont know how Myth EPG will deal with 2 inputs, what happens when BBC 1 is on both, what happens when a program is on DVB-T DVB-S and DVB-S2 at the same time? Jeff

comment:7 Changed 10 years ago by Stuart Auchterlonie

Ticket locked: set

Use the -users list for help setting stuff up correctly.

comment:8 Changed 10 years ago by sphery

ref #7862

comment:9 Changed 10 years ago by robertm

Resolution: fixed
Status: newclosed

Reporter appears to have solved his configuration issue. As an aside, it appears the default firmware and driver for this device were a total disaster until very recently. I'm asking that anyone considering opening a ticket with a tuning or scanning issue with the HVR-4000 compile current v4l-dvb modules and get a current firmware installed (not the packaged one).

Note: See TracTickets for help on using tickets.