Opened 10 years ago

Closed 10 years ago

#7684 closed defect (fixed)

Subtitles on 4:3 recordings are stretched and off-screen

Reported by: stalks <svn.mythtv.org@…> Owned by: stuartm
Priority: minor Milestone: 0.23
Component: MythTV - Video Playback Version: head
Severity: medium Keywords: subtitles
Cc: Ticket locked: no

Description

Upgraded from 22208 to 22917 (2009-11-28 22:07:27) ~2days old

Compiled from: 22917
OS: Linux Debian Squeeze amd64
Kernal: 2.6.31-1-amd64
Graphics Card: Asus 8400GS 512MB
Nvidia Drivers: 190.42
Resolution: 1280x720

Subtitles in 4:3 showings are larger, stretched and go off-screen. See attached photo for example.

16:9 shows display correctly.

I am watching UK DVB and justinh tells me these are bitmap type subtitles.

Example show: Doctor Quinn on ITV2 UK DVB.

What I have tried so far:

  • Zoom at Auto Detect (Default Off), Auto Detect (Default Half), Half, Full, H.Stretch. This stetched the video but the subtitles remain unaffected.
  • Aspect Ratio at Off, 4:3, 14:9, 16:9. This stretched the video but the subtitles remain unaffected.
  • Renderer type of OpenGL, VDPAU and XVideo.
  • Text zoom, Font type in ATSC Settings (before I was told these are bitmaps, not text).
  • Tried each standard supplied Theme and OSD Theme.

My wife is deaf so is unable to watch her favourite shows. I'm told that until she can watch Doctor Quinn again the bedroom is off limits out of sleeping hours. Help!

Attachments (1)

mythtv-subs.jpg (113.2 KB) - added by stalks <svn.mythtv.org@…> 10 years ago.
Photo example of stretched subtitles

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by stalks <svn.mythtv.org@…>

Attachment: mythtv-subs.jpg added

Photo example of stretched subtitles

comment:1 Changed 10 years ago by stuartm

Milestone: unknown0.23
Owner: changed from Janne Grunau to stuartm
Severity: highmedium
Status: newassigned

You will have to downgrade to [22583] until I have time to fix this properly. Welcome to trunk.

comment:2 Changed 10 years ago by stalks <svn.mythtv.org@…>

Aha, thankyou for the revision number. I was 'quicksort'ing between [22208] and [22917] to find the revision.

Manually reverting the changes made in [22584] to mythtv/libs/libmythtv/NuppelVideoPlayer.cpp in HEAD has fixed this issue.

Wub <3

comment:3 Changed 10 years ago by stuartm

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.