Opened 10 years ago

Closed 9 years ago

#7697 closed defect (duplicate)

HD LiveTV fails on the hour with "Error: Video frame buffering failed too many times."

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have a backend with multiple frontends all running 22924 (be & fe's). The backend has two hdhr's a pchdtv 5500 and an SD hauppauge 150. Watching live HD tv on any frontend using either VDPAU Slim or Normal profiles results in consistently getting "Error: Video frame buffering failed too many times." at the top of the hour (ie; 1:00, 3:00, etc). Frontends have either NVIDIA 9500GT w/ 1gb or NVIDIA 9400 w/ 1gb. SD content so far has tested ok, but has only been tested a small amount.

This problem has persisted since upgrading to .22. Did not observe this behavior in .21 but did not watch live tv in .21.

I am happy to provide any details needed to help resolve this issue.

Attachments (4)

error.log (8.9 KB) - added by anonymous 10 years ago.
Attached file shows one instance of the probelm described. in the log everything is going fine until timestamp 16:00:02. This problem occurs consistently on the top of the hour and is repeatable on multiple frontends.
dmesg.sav (123.2 KB) - added by John Luber <john@…> 10 years ago.
mythbackend.sav (23.4 KB) - added by John Luber <john@…> 10 years ago.
mythfrontend.sav (9.5 KB) - added by John Luber <john@…> 10 years ago.

Download all attachments as: .zip

Change History (16)

Changed 10 years ago by anonymous

Attachment: error.log added

Attached file shows one instance of the probelm described. in the log everything is going fine until timestamp 16:00:02. This problem occurs consistently on the top of the hour and is repeatable on multiple frontends.

comment:1 Changed 10 years ago by John Luber <john@…>

Seems the ticket didn't capture my contact info. email to john at luberfamily dot net

comment:2 Changed 10 years ago by John Luber <john@…>

Update: I have confirmed the problem also happens using SD livetv as well. Also, I found this ticket - 6583 - which sounds identical to the issue I am having. However, 6583 seems to indicate that the problem is resolved; if so I can confirm that it is not resolved - at least not for me :)

comment:3 Changed 10 years ago by sphery

refs #6583 , refs #6612

comment:4 Changed 10 years ago by robertm

Status: newinfoneeded_new

John,

Can you provide mythfrontend, mythbackend, and dmesg output for this problem? Default verbosity should be fine for now, but please don't edit the logs, make them from backend and frontend startup-- so restart the backend and start capturing the log, restart the frontend, start livetv, and wait for the problem to happen. Then get dmesg, and post all of the above here.

comment:5 in reply to:  4 Changed 10 years ago by John Luber <john@…>

Replying to robertm:

John,

Can you provide mythfrontend, mythbackend, and dmesg output for this problem? Default verbosity should be fine for now, but please don't edit the logs, make them from backend and frontend startup-- so restart the backend and start capturing the log, restart the frontend, start livetv, and wait for the problem to happen. Then get dmesg, and post all of the above here.

Robert,

I am not sure I know how to capture the dmesg output, can you give me an example of the command you need me to execute and I will do that.

Also, I think I've learned more about this problem than when I initially reported it. I believe what is going on is when watching live tv the stream is written to a file and it is actually the file that is being watched; at least that what I understand based upon reading the various threads. Further, the problem seems to occur when the file is changed ie; when one show ends and another starts. So, it is not just on the hour but also on the half hour if a show stops and another starts on the half hour.

If the above is correct then I believe what is happening is some sort of delay while one file closes and another is opened.

Last, the severity of the problem has become much less since I wrote th original ticket. Now, rather than getting the error message "Error: Video frame buffering failed too many times." as the one program ends and another begins I just see a brief 1-2 second stutter in the display. For example, live tv may pause for 1-2 seconds and then resume without any further issues until the next transition from one show to another.

John

comment:6 Changed 10 years ago by robertm

John,

You can just run the "dmesg" command and capture the last few hundred lines of output.

Your assessment of how liveTV works is more or less accurate, but it's impossible to speculate why the issue occurs without a deeper look. Let's start with the requested logs and see if we can figure it out.

Changed 10 years ago by John Luber <john@…>

Attachment: dmesg.sav added

Changed 10 years ago by John Luber <john@…>

Attachment: mythbackend.sav added

Changed 10 years ago by John Luber <john@…>

Attachment: mythfrontend.sav added

comment:7 in reply to:  6 Changed 10 years ago by John Luber <john@…>

Replying to robertm:

John,

You can just run the "dmesg" command and capture the last few hundred lines of output.

Your assessment of how liveTV works is more or less accurate, but it's impossible to speculate why the issue occurs without a deeper look. Let's start with the requested logs and see if we can figure it out.

Robert,

I've attached the requested files. I forgot to cut the dmesg file down to 100 prior to uploading - sorry. I did not see an error message at the switch from one program to the next just the brief 1-2 second pause.

Happy to provide any other info you might need.

John

comment:8 Changed 10 years ago by robertm

Status: infoneeded_newnew

comment:9 Changed 10 years ago by shifty <shiftybugger@…>

I am also experiencing this problem on program change. LiveTV crashes are rare, but a 1-2 second pause occurs on every program change, in both HD and SD tv. I am running 22594 on both FE and BE and use VDPAU Slim for playback. I'm happy to provide a set of logs if it would be helpful.

comment:10 Changed 9 years ago by John.D.Nourse@…

HI, my son and I have both MythTV setups with both front and back end UBUNTU boxes, and this problem for us has been occurring with Live TV but only with On Air shows. The message appears on all of our front ends I see the same shudder when the HD on air shows change. I'm not 100% positive but it seems to me I consistently see the issue when during th live show I pause it and then resume. I know this because the error occurs when the show has ended in real time and I am behind and miss the end of the show because I paused it and did not catch up with the live real time show before it ended. Very annoying!!

OK. This has been going on for a long time now probably close to a year but it has ben so long I don't actually remember the start date. Our Back end stats show that we have been recording shows on Myth for 1 year and 13 months but I do not remember seeing this initially. If requested I will try to create and provide log files as requested above. My son's setup has high def satellite from Starchoice. This does not seem to have the issue on it's high def. I have however noticed that the On Air High Definition files are huge at least twice the size of the HD files from the Star Choice box. We are both using the HDHomerun box to get the On Air digital signals onto our gigabit home networks and through to MythTV. We both use VDPAU for all the digital processing on all boxes including High Definition .

I hope this helps isolate the issue. I understand that each show either recorded or Live is actually recorded as a separate file. This makes the message relevant if there is some problem concluding writing and closing the Live TV recording before being able to start recording the subsequent live show.

I hope these insights help. Regards,

John Nourse

comment:11 Changed 9 years ago by wackston@…

Experiencing the same issues here with Free-to-air DVB-S2 HDTV from the German national broadcasters over Astra.

MythTV 0.23+fixes (mythbuntu: 0.23.0+fixes24158-0ubuntu2) Configuration backend server

3X Hauppauge WinTV-Nova-HD-S2 1X Hauppauge WinTV-Nova-S-plus

Frontend

Nvidia9500GT VDPAU various profiles (problem seems unaffaected.

I've spent lots of time trying to narrow things down varying the configuration - both frontend playback and options for connecting to BE (e.g. forcing streaming from server vs. directory shared via NFS). The problem seems unaffected. Very happy to assist in further debugging (extracting logs, trying patches etc etc).

comment:12 Changed 9 years ago by robertm

Resolution: duplicate
Status: newclosed

Dupe of #7472.

Note: See TracTickets for help on using tickets.