Opened 10 years ago

Closed 6 years ago

#7701 closed Patch - Feature (Won't Fix)

Enhance channel.conf import

Reported by: martin@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Channel Scanner Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

If somebody adds the transponders manually or imports a channel.conf file, the TID and NID does not get updated in the dtv_multiplex table. This seems to not harm the ability of viewing Live TV; but the EITScanner is unable to get the Guide data.

Additionally theres no field in the "add transponders" - menu of mythtv-setup to insert them.

As long as a "Full Scan" on a frequency is performed - TID and NID are inserted correctly. Do a full scan or insert the right values in the dtv_multiplex table and the EITScanner works.

Attachments (3)

0005-Teach-DTVMultiplex-and-the-channels.conf-importer-ab.patch (6.2 KB) - added by dekarl@… 8 years ago.
patch written to file format description (untested)
0001-unbreak-the-channels.conf-importer-for-DVB.patch (7.4 KB) - added by dekarl@… 8 years ago.
extended patch, now with more brains
0001-unbreak-DVB-channels.conf-compile-tested.patch (7.4 KB) - added by dekarl@… 8 years ago.
third version, now compiles without error, doh.

Download all attachments as: .zip

Change History (25)

comment:1 in reply to:  description Changed 10 years ago by anonymous

Replying to martin@…:

I can confirm that problem still there. Rescanning from channels.conf kills EID. Manual tuned scan makes it works.

mythbackend version: branches/release-0-22-fixes [22594] www.mythtv.org

If somebody adds the transponders manually or imports a channel.conf file, the TID and NID does not get updated in the dtv_multiplex table. This seems to not harm the ability of viewing Live TV; but the EITScanner is unable to get the Guide data.

Additionally theres no field in the "add transponders" - menu of mythtv-setup to insert them.

As long as a "Full Scan" on a frequency is performed - TID and NID are inserted correctly. Do a full scan or insert the right values in the dtv_multiplex table and the EITScanner works.

comment:2 Changed 10 years ago by Kaacz

still same in trunk [23330] too ..

comment:3 Changed 9 years ago by mythtv@…

This also appears to have the side affect of crashing the DVB-T HDHomerun

If a mux hasnt been correctly updated with the TID or NID attempting to view any channel within it causes the mythbackend log to fill up with:

"HDHRSH::TunerSet?() Failed. Trying qam_16:546000000" (number depending on the mux)

The frontend then dumps with an 'irrecoverable tuner error' and the backend eventually crashes.

Inserting the TID or NID manually, or by a full scan fixes this

comment:4 Changed 9 years ago by glemsom@…

I can confirm this issue is still in mythtv-0.23@25427.
Some users are relying on importing a channel.conf - since a full-scan from MythTV does not find all channels (NOT related to this bug!).

comment:5 Changed 9 years ago by robertm

Status: newassigned

comment:6 Changed 9 years ago by niels@…

I found a related problem, ie the EIT scanner is correctly activated etc, but no EIT data is processed. After some debugging it seems the dvbstreamdata isn't activated, but just the mpegstreamdata. Sofar I found that in tv_rec.cpp TVRec::SetupDTVSignalMonitor, the tuningmode isn't equal to 'dvb' but has 'mpeg'. When I remove the extra check on tuningmode == dvb, the EIT scanner starts to function. Hope this helps in finding why EIT seems to fail.

comment:7 Changed 9 years ago by Stuart Auchterlonie

Hmmmm, if the channels are marked as "mpeg" and not as "dvb" then that is potentially a problem in the channel scanner rather than in EIT itself.

Stuart

comment:8 Changed 9 years ago by Niels Nes <niels@…>

could I check the mysql dtv* or channels table to see if the channel scanner made some mistake. Channels were scanned in the channels.conf/delete all/scan - using known transports.

Niels

comment:9 Changed 9 years ago by Niels Nes <niels@…>

could it be that sistandard in the dtv_multiplex should be filled in (now empty) for all transports?

comment:10 Changed 9 years ago by Niels Nes <niels@…>

After setting the dtv_multiplex.sistandard for my dvb-c cards to dvb, the non-patched version also works. ie when loading the transports via channel.conf may also have caused the problem.

comment:11 Changed 9 years ago by stuartm

We have always stated that EIT would not work if channels are imported via channels.conf and that's why we do not recommend the use of channels.conf instead of the internal scanner.

Yes the internal scanner has it's faults, but too few users bother to report them meaning they will never get fixed.

comment:12 Changed 9 years ago by Niels Nes <niels@…>

the internal scanner failed indeed, but could very well be caused by a bad cable (did that scan some time ago). For various posts I saw that EIT doesn't work with channels.conf. Some however do report success with re-using the transports from this scan. That clearly doesn't work if the networkid and sistandard aren't correct. All fixable by a simple (for dvb only setup)

update dtv_multiplex set networkid = <networkid>, sistandard = 'dvb'; anyway thanks for the help.

comment:13 Changed 8 years ago by anonymous@…

I can confirm that problem still there. Rescanning from channels.conf kills EID. Manual tuned scan makes it works.

mythbackend version: branches/release-0-22-fixes [22594] www.mythtv.org

If somebody adds the transponders manually or imports a channel.conf file, the TID and NID does not get updated in the dtv_multiplex table. This seems to not harm the ability of viewing Live TV; but the EITScanner is unable to get the Guide data.

Additionally theres no field in the "add transponders" - menu of mythtv-setup to insert them.

As long as a "Full Scan" on a frequency is performed - TID and NID are inserted correctly. Do a full scan or insert the right values in the dtv_multiplex table and the EITScanner works.

comment:2 Changed 20 months ago by Kaacz

still same in trunk [23330] too ..

comment:3 Changed 18 months ago by mythtv@…

This also appears to have the side affect of crashing the DVB-T HDHomerun

If a mux hasnt been correctly updated with the TID or NID attempting to view any channel within it causes the mythbackend log to fill up with:

"HDHRSH::TunerSet??() Failed. Trying qam_16:546000000" (number depending on the mux)

The frontend then dumps with an 'irrecoverable tuner error' and the backend eventually crashes.

Inserting the TID or NID manually, or by a full scan fixes this

comment:4 Changed 14 months ago by glemsom@…

I can confirm this issue is still in mythtv-0.23@25427. Some users are relying on importing a channel.conf - since a full-scan from MythTV does not find all channels (NOT related to this bug!).

comment:5 Changed 14 months ago by robertm

Status changed from new to assigned comment:6 Changed 14 months ago by niels@…

I found a related problem, ie the EIT scanner is correctly activated etc, but no EIT data is processed. After some debugging it seems the dvbstreamdata isn't activated, but just the mpegstreamdata. Sofar I found that in tv_rec.cpp TVRec::SetupDTVSignalMonitor, the tuningmode isn't equal to 'dvb' but has 'mpeg'. When I remove the extra check on tuningmode == dvb, the EIT scanner starts to function. Hope this helps in finding why EIT seems to fail.

comment:7 Changed 14 months ago by stuarta

Hmmmm, if the channels are marked as "mpeg" and not as "dvb" then that is potentially a problem in the channel scanner rather than in EIT itself.

Stuart

comment:8 Changed 14 months ago by Niels Nes <niels@…>

could I check the mysql dtv* or channels table to see if the channel scanner made some mistake. Channels were scanned in the channels.conf/delete all/scan - using known transports.

Niels

comment:9 Changed 14 months ago by Niels Nes <niels@…>

could it be that sistandard in the dtv_multiplex should be filled in (now empty) for all transports?

comment:10 Changed 14 months ago by Niels Nes <niels@…>

After setting the dtv_multiplex.sistandard for my dvb-c cards to dvb, the non-patched version also works. ie when loading the transports via channel.conf may also have caused the problem.

comment:11 Changed 14 months ago by stuartm

We have always stated that EIT would not work if channels are imported via channels.conf and that's why we do not recommend the use of channels.conf instead of the internal scanner.

Yes the internal scanner has it's faults, but too few users bother to report them meaning they will never get fixed.

comment:12 Changed 14 months ago by Niels Nes <niels@…>

the internal scanner failed indeed, but could very well be caused by a bad cable (did that scan some time ago). For various posts I saw that EIT doesn't work with channels.conf. Some however do report success with re-using the transports from this scan. That clearly doesn't work if the networkid and sistandard aren't correct. All fixable by a simple (for dvb only setup)

Comprar el Dolar Hoy

update dtv_multiplex set networkid = <networkid>, sistandard = 'dvb'; anyway thanks for the help.

comment:14 Changed 8 years ago by stuartm

Resolution: Invalid
Status: assignedclosed
Ticket locked: set

As stated a year ago, this isn't a bug, it's a limitation of using channel.conf instead of the internal scanner. Closing this as invalid since it's at best a feature request without patch - at worst it's about extending a temporary workaround instead of fixing internal scanner bugs.

Changed 8 years ago by dekarl@…

patch written to file format description (untested)

Changed 8 years ago by dekarl@…

extended patch, now with more brains

Changed 8 years ago by dekarl@…

third version, now compiles without error, doh.

comment:15 Changed 8 years ago by stuartm

Resolution: Invalid
Status: closednew
Ticket locked: unset
Version: 0.22-fixesMaster Head

comment:16 Changed 8 years ago by stuartm

Milestone: unknown0.25
Owner: changed from Stuart Auchterlonie to danielk
Status: newassigned
Type: defectPatch - Bug Fix

May not be as simple as it looks, but there's a patch and it's an issue which seems to generate a lot of feedback from users.

comment:17 Changed 8 years ago by stuartm

Component: MythTV - EITMythTV - Channel Scanner

comment:18 Changed 8 years ago by danielk

Milestone: 0.250.26
Summary: EIT does not get updated when inserting transponders manuallyEnhance channel.conf import
Type: Patch - Bug FixPatch - Feature

I'd rather drop channel.conf import and just improve the internal scanner, but for now just push this to 0.26 since it is really feature.

comment:19 Changed 7 years ago by danielk

Milestone: 0.260.27

comment:20 Changed 7 years ago by jerry.baum@…

3 years later, problem still exists. channels.conf import still broken although a patch was submitted, and users are being told it's a feature and not a bug. way to go!

comment:21 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Ticket locked: set

comment:22 Changed 6 years ago by stuartm

Milestone: 0.27unknown
Resolution: Won't Fix
Status: assignedclosed

There's just no interest in fixing channel.conf import, it was only ever a workaround for problems in the internal scanner and as long as the import option exists it's a distraction from fixing the real problems.

Note: See TracTickets for help on using tickets.