Opened 10 years ago

Closed 10 years ago

#7713 closed defect (invalid)

Bad playback about DVB

Reported by: Bánó Gábor <banogabor@…> Owned by: Janne Grunau
Priority: minor Milestone: 0.23
Component: MythTV - Video Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I'm watched a playback problem for some time past. When I'd like to play back a DVB recording or DVB live TV broadcasting, I almost always meet with problem. I'm think this is a timing issue, but not always comes away.

I found a method to recognise this problem. Inside one playback, the mythfrontend produce both of state. Just have to use jumping with arrow keys.

I'm note these video files playable correctly every video player on linux, included mplayer with vdpau support.

please fix this error

I'm attached my playback messages of my mythfrontend

Attachments (1)

playback-issue.txt (26.5 KB) - added by Bánó Gábor <banogabor@…> 10 years ago.
Strange playback issue in mythfrontend. Watch the fps!

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Bánó Gábor <banogabor@…>

Attachment: playback-issue.txt added

Strange playback issue in mythfrontend. Watch the fps!

comment:1 Changed 10 years ago by Bánó Gábor <banogabor@…>

I'm missed, the problem is about playback fps! When the fps is 25, the playback is perfect, if not, the playback is jerky.

comment:2 Changed 10 years ago by markk

Status: newinfoneeded_new

Can you confirm whether this is fixed in trunk? thanks, Mark

comment:3 Changed 10 years ago by Bánó Gábor <banogabor@…>

Still no, because I couldn't compile the newer versions. I've got a missing reference error, when the compile reach the Playbackbox.cpp. I cannot step over. If you help me how to fix this error, after I'll check the DVB playback and reply about it.

comment:4 Changed 10 years ago by Bánó Gábor <banogabor@…>

I'got a little bit of time to fix my compilation environment, so I'm compiled the 23514 trunk version succesfully. I made long test on DVB playback. The result: the playback fps changes continuously. I'm watched a studio talk show: With less moving (ie. mouth moving) the fps was good, but at a camera changing or at quick, great moving, the fps falls down to 23,5. The broadcasted movies and ads are unwatchable, because the fps falling down and the displayed films playing aren't smoothly. Very bad (sorry).

About my system:

Server: Intel 82945 mini ITX

Intel Atom 330 (1,6 GHz, dual-core, hyper-threading) 1Gb ram 1TB HDD USB Freecom DVB-T receiver stick connected on a roof antenna USB Hauppauge PVR2 analog (mpeg2, ivtv) receiver Gigabit LAN Ubuntu 9.10 server I386

Client Asus Nvidia GeForce? 8200 mainboard (with vdpau support)

AMD 7850 BE (2,6 dual core) 2Gb ram 200Gb HDD Gigabit LAN Ubuntu 9.10 desktop AMD64

comment:5 Changed 10 years ago by paulh

Status: infoneeded_newnew

comment:6 Changed 10 years ago by robertm

Resolution: invalid
Status: newclosed

2009-12-06 20:04:11.898 Using video as timebase

Note: See TracTickets for help on using tickets.