Modify

Opened 8 years ago

Closed 7 years ago

#7728 closed defect (invalid)

Technotrend 1500 S: can scan, but tuning is difficult

Reported by: Peter Bienstman <Peter.Bienstman@…> Owned by: ijr
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.22-fixes
Severity: medium Keywords: disecq, multytenne, technotrend
Cc: Ticket locked: no

Description

I have a Technotrend 1500 DVB-S card connected to a TV Vlaanderen Triple Sat dish (basically a modified Multytenne with LNB 4 removed).

Doing a scan both on LNB 1 (Astra 1) and on LNB 3 (Astra 2) seems to find all the channels just fine. However, when watching the (FTA) LNB 1 channels, some work, but most don't get further than 'partial lock', although I can watch all of these channels without problems in Kaffeine. For LNB 3, I was even unable to find any channel that fully locks.

http://svn.mythtv.org/trac/ticket/5703 mentions something similar, although there it was suggested that setting the number of DiSEqC repeats to 0 solves this. I've tried values of 0, 1 and 5, but none work.

I've tried this both on a Ubuntu 9.04 and 9.10 system.

Attachments (1)

myth.log (29.2 KB) - added by Peter Bienstman <Peter.Bienstman@…> 8 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 8 years ago by Peter Bienstman <Peter.Bienstman@…>

OK, it's definitely a DiSEqC problem. I've compared the output of Kaffeine and MythTV

For channel BVN on LNB 1 everything is OK, and Myth and Kaffeine agree:

Kaffeine: Tuning to: BVN / autocount: 0 Using DVB device 0:0 "ST STV0299 DVB-S" tuning DVB-S to 12574000 h 22000000 inv:2 fecH:5 DiSEqC: switch pos 0, 18V, hiband (index 3) DiSEqC: e0 10 38 f3 00 00

MythTv?: 2009-12-09 21:36:05.436 DiSEqCDevTree: Changing to DiSEqC switch port 1/4 2009-12-09 21:30:00.017 DiSEqCDevTree: Sending DiSEqC Command: e0 10 38 f3

But for BBC1, Myth thinks it's located on LNB 1, whereas it should look on LNB 3:

Tuning to: BBC 1 London / autocount: 1 Using DVB device 0:0 "ST STV0299 DVB-S" tuning DVB-S to 10773000 h 22000000 inv:2 fecH:5 DiSEqC: switch pos 2, 18V, loband (index 9) DiSEqC: e0 10 38 fa 00 00

2009-12-09 21:32:23.656 DiSEqCDevTree: Changing LNB voltage to 18V 2009-12-09 21:32:23.674 DiSEqCDevTree: Changing to DiSEqC switch port 1/4 2009-12-09 21:32:23.675 DiSEqCDevTree: Sending DiSEqC Command: e0 10 38 f2

It seems that after scanning, Myth forgets BBC 1 is located on LNB 3...

Changed 8 years ago by Peter Bienstman <Peter.Bienstman@…>

comment:2 Changed 8 years ago by Peter Bienstman <Peter.Bienstman@…>

Turns out that if I create two separate video sources (as opposed to two different connection to the same source) it works ok.

Not sure if this is intended behaviour, but it certainly is confusing...

comment:3 Changed 7 years ago by mdean

  • Resolution set to invalid
  • Status changed from new to closed

As the OP found, multiple video sources are required for the described configuration because some of the DiSEqC data is stored in the video source.

Add Comment

Modify Ticket

Action
as closed The owner will remain ijr.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.