Opened 10 years ago

Closed 9 years ago

#7737 closed defect (fixed)

MythWeb - Program information is missing after pushing "update recording settings" button

Reported by: wstotz@… Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: 0.22-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Start at program listings page.

Click on a program, which takes you to the page to set up a recording of that program.

Click on "Record Only This showing" (other choices might be similar)

Scroll to bottom of page and click on "Update recording settings"

The page reloads, but most of the program info such as Episode number, Original Air Date, etc is gone. Also gone is the MythTV status, and possible conflicts info.

Below that, the "More" section has changed. Most significantly, the option to return to your place in the listings screen is gone and has been replaced by "Back to the recording schedules"

Also, clicking the link to hide the advanced optioins dumps me out to the mythweb welcome screen (mythweb/#)

version 22594

Change History (4)

comment:1 Changed 10 years ago by otto at kolsi dot fi

dup of #7660 ?

See also #6601 for some details, that ticket is also about the same problem and it has not yet been fixed although that ticket was closed.

comment:2 Changed 10 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

I did some investigation into this a couple of weeks ago. Details here:

http://www.gossamer-threads.com/lists/mythtv/users/410979

comment:3 Changed 10 years ago by sphery

Summary: Mythweb set recording page is wrong after pushing "update recording settings" buttonMythWeb - Program information is missing after pushing "update recording settings" button

Of the multiple issues reported on the tickets:

#6601 was taken to be a "recording status is not properly updated after changing schedule" ticket (and that has been fixed). (The part about, "Back to program listings link is broken," will be handled by #7660.)

#7660 reports only one issue, "Back to program listings link is broken".

#7737 (this ticket) reports a duplicate of #7660 ("Back to program listings link is broken"), a duplicate of #7606 ("Link to hide the advanced options goes to main page"), and "Program information missing after update."

All that's not duplicated on this ticket is the last, "Program information missing after update."

One issue per ticket, please.

comment:4 Changed 9 years ago by Rob Smith

Resolution: fixed
Status: newclosed

(In [24915]) Fixes #7737, this has the schedule post back to the correct place

Note: See TracTickets for help on using tickets.