Opened 10 years ago

Closed 10 years ago

#7753 closed defect (fixed)

Upcoming Episodes Screen is broken

Reported by: skd5aner <skd5aner@…> Owned by: stuartm
Priority: minor Milestone: 0.23
Component: MythTV - General Version: 0.22-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using .22-fixes, I am no longer able to see the "Upcoming Episodes" screen. I do not believe that it has worked since my upgrade from .21 to .22.

  • What I would expect to happen/see:

The Upcoming Episodes screen typically shows any instances of a program which myth is aware of in the schedule. When I click the upcoming episodes button, a screen should show up showing all episodes of that program (similar to how the "Upcoming Recordings" screen works for a program). This worked as expected in .21

  • What I actually experience/see:

When I select "Upcoming episodes" from the "Schedule Information" dialog menu, all that happens is that the menu is closed and I'm taken back to the main recording rule page.

  • Steps to Reproduce:

1) From Main Menu, go to "Manage Recordings" 2) Select "Recording Rules" 3) Select a Rule for a program that you know has upcoming episodes 4) Once in the Rule, Go to "Schedule Info" 5) Select "Upcoming episodes" from the context menu"

You should then be instantly sent back to the Recording Rule screen and will not see the upcoming episode screen.

I've tested with both Graphite and Terra, with the same results. I'm running .22-fixes, r22952. Here is the output from mythfrontend --version Please include all output in bug reports. MythTV Version : 22954M MythTV Branch : branches/release-0-22-fixes Network Protocol : 50 Library API : 0.22.20091023-1 QT Version : 4.5.2 Options compiled in:

linux profile using_oss using_alsa using_pulse using_backend using_directfb using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

Please let me know if there's any additional information, logging, or details that I can provide to help troubleshoot this issue.

Change History (6)

comment:1 Changed 10 years ago by stuartm

Milestone: unknown0.22.1
Status: newinfoneeded_new

I can't reproduce this with trunk. I'm unaware of any fixes which weren't backported but if you can find one I'd be happy to apply it to the -fixes branch.

comment:2 Changed 10 years ago by Mike Rice <mikerice1969@…>

I also can reproduce this on 0.22 so I brought it up in the debugger to see what was going on. Unfortunately I'm not running trunk at the moment so I can't debug that to see why it is apparently working there. I did look at the trunk source and it appears to be basically the same as 0.22 for this stuff...

Anyway the ScheduleEditor? class can be constructed two ways. One constructor is passed a RecordingInfo? which is used to initialize m_recInfo. The other (which is used in this case) is passed a RecordingRule? and m_recInfo is set to NULL.

When the "Upcoming episodes" button is handled in the schedinfo dialog it calls showUpcomingByTitle(). This routine call ShowUpcoming?(m_recInfo) but since m_recInfo is NULL it immediately returns. This produces the behavior described in the original report.

Note also that hitting "Program Details" from this dialog when ScheduleEditor? is created via a RecordingRule? also "does nothing" since there is no related single program. I think it would be better to just not add this button to the dialog when m_recInfo is NULL rather than handling it with a no-op.

stuartm: when you stop in ScheduleEditor::showUpcomingByTitle() is m_recInfo NULL for you when coming in through the RecordingRule? path? If not where is m_recInfo set?

comment:3 Changed 10 years ago by stuartm

Status: infoneeded_newnew

Ok I can see a scenario under which you'd see this behaviour, namely editing rules from screens where they aren't explicitly attached to upcoming recordings. e.g. I can't reproduce from the 'Upcoming Recordings' screen since by definition those are attached to entries in the programs table, but I can reproduce from the 'Recording Rules' screen.

I'll have to look back at 0.21 to see how this was handled back then, it may be a while before I have the time.

comment:4 Changed 10 years ago by Stuart Auchterlonie

Milestone: 0.22.10.23

Is this one doable for 0.23?

comment:5 Changed 10 years ago by stuartm

Owner: changed from Isaac Richards to stuartm
Status: newaccepted

comment:6 Changed 10 years ago by stuartm

Resolution: fixed
Status: acceptedclosed

(In [23374]) Fix the 'Upcomming Episodes' option when editing a rule under some conditions. Fixes #7753

Note: See TracTickets for help on using tickets.