Opened 10 years ago

Closed 9 years ago

#7767 closed defect (fixed)

Editing a 2nd channel in live TV locks up UI

Reported by: Bob Shanteau <rmshant@…> Owned by: markk
Priority: minor Milestone: 0.24
Component: MythTV - Video Playback Version: 0.22
Severity: medium Keywords:
Cc: Ticket locked: no

Description

While watching live TV, hit E to edit the channel. Hit Esc, change the channel, then hit E again. UI locks up, requiring a reboot.

Change History (9)

comment:1 in reply to:  description Changed 10 years ago by anonymous

Replying to Bob Shanteau <rmshant@…>:

While watching live TV, hit E to edit the channel. Hit Esc, change the channel, then hit E again. UI locks up, requiring a reboot.

I had the same problem in Mythbuntu 9.10. I changed over to Gentoo (for other reasons) and I still have the same problem running myth 0-22-fixes. I have tried with and without fluxbox running in the background, and this has no effect. The UI appears to have quit accepting keyboard events since it still is playing the stream correctly.

comment:2 Changed 10 years ago by stuartm

Component: MythTV - User Interface LibraryMythTV - Video Playback
Owner: changed from stuartm to Janne Grunau

comment:3 Changed 10 years ago by Marc Randolph <mrand@…>

There are a few different users that have reported this. The four Ubuntu users at https://bugs.launchpad.net/ubuntu/+source/mythtv/+bug/467146 all appear to be using digital sources:

Nova-T-500
2 x KNC1 DVB-C 
HVR-1250
HVR-2250

As the atrpms user in bug #7007 mentions, there is nothing useful in the default logs.

comment:4 Changed 10 years ago by sphery

ref #8077

comment:5 Changed 10 years ago by sphery

Bob Shanteau on #8077 mentioned that after changing the Playback Profile group, Edit Channel worked properly. Users wanting to test should probably try the Slim Playback Profile group. Or, try changing just the deinterlacer (from--my guess--bobdeint to something like linear or onefield) and see if that prevents the issue.

comment:6 Changed 10 years ago by anonymous

Bug only happens if you have browse channels enabled. And it only happens when you edit the channel after chaning from one channel to another.

comment:7 Changed 9 years ago by robertm

Owner: changed from Janne Grunau to markk
Status: newassigned

Mark, assigning since you have the Live TV channel editor-- this bug is likely no longer applicable as IIRC the live tv channel editor is disabled entirely for now.

comment:8 Changed 9 years ago by markk

Milestone: unknown0.24
Status: assignedaccepted

see also #8760

comment:9 Changed 9 years ago by markk

Resolution: fixed
Status: acceptedclosed

The Channel Editor was fixed in r26432 and I cannot reproduce this with a variety of different playback profiles and settings.

Note: See TracTickets for help on using tickets.