Opened 10 years ago

Closed 10 years ago

#7788 closed defect (fixed)

Delete of LiveTV does not work

Reported by: Matthew T. Russotto <mrussotto@…> Owned by: Isaac Richards
Priority: minor Milestone: 0.23
Component: MythTV - General Version: 0.22-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This is NOT a duplicate of 7342; I would have liked to re-open that but apparently that's not allowed.

The fix in 7342 is unfortunately not sufficient to solve the problem of deleting LiveTV recordings in MythFrontend. It now fails if you attempt to delete a LiveTV program when the group filter is set to LiveTV, because in that case the LiveTV group is not used and the LiveTV programs are in the aggregate group. Fortunately the fix is simple; I will attach.

Attachments (1)

41_fix_live_delete.dpatch (1000 bytes) - added by Matthew T. Russotto <mrussotto@…> 10 years ago.
Fix for livetv delete

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by Matthew T. Russotto <mrussotto@…>

Attachment: 41_fix_live_delete.dpatch added

Fix for livetv delete

comment:1 Changed 10 years ago by sphery

Milestone: unknown0.23
Resolution: fixed
Status: newclosed
Version: unknown0.22-fixes

I cannot duplicate this in trunk. I tried with Group View set to include and not include "Show LiveTV", with Group Filter set to LiveTV and with Group Filter set to All Programs, with and without the 'Show filter name instead of "All Programs"' setting enabled.

If you can still reproduce this on current trunk, please say so and give instructions for duplicating the issue--including the exact settings in Change Group View and Change Group Filter as well as whether or not you've enabled, 'Show filter name instead of "All Programs"' or not.

Note: See TracTickets for help on using tickets.