Opened 10 years ago

Closed 9 years ago

#7797 closed defect (fixed)

mythfrontend crash

Reported by: David <idht4n@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by sphery)

I saw this crash in mythfrontend in mythbuntu 9.10:

[gdb backtrace attached]

MythTV Version   : 22594
MythTV Branch    : branches/release-0-22-fixes
Network Protocol : 50
Library API      : 0.22.20091023-1
QT Version       : 4.5.2
Options compiled in:
 linux profile using_oss using_alsa using_pulse using_jack using_backend using_dvb using_firewire using_frontend using_glx_proc_addr_arb using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

Attachments (2)

bt2.txt (13.0 KB) - added by idht4n@… 10 years ago.
another crash backtrace
glibc_backtrace.log (7.1 KB) - added by sphery 9 years ago.
glibc backtrace from original description, removed to make ticket readable.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by sphery

Status: newinfoneeded_new

comment:2 in reply to:  1 Changed 10 years ago by David <idht4n@…>

Replying to mdean:

We really need a proper backtrace for this one, as described at http://www.mythtv.org/wiki/Debugging and http://svn.mythtv.org/trac/wiki/TicketHowTo and http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2 .

I had tried to install debugging packages as was documented in http://www.mythtv.org/wiki/Debugging "Debugging with Ubuntu packages":

sudo apt-get install mythtv-dbg mythplugins-dbg Reading package lists... Done Building dependency tree Reading state information... Done E: Couldn't find package mythtv-dbg

Changed 10 years ago by idht4n@…

Attachment: bt2.txt added

another crash backtrace

comment:3 Changed 9 years ago by sphery

Description: modified (diff)
Status: infoneeded_newnew

Removing inline glibc backtrace from the description to make the ticket readable and attaching as a file (just to preserve the original information).

gdb backtrace has been provided, as requested.

Changed 9 years ago by sphery

Attachment: glibc_backtrace.log added

glibc backtrace from original description, removed to make ticket readable.

comment:4 Changed 9 years ago by sphery

Resolution: fixed
Status: newclosed

This looks like a VDPAU issue, based on the backtrace and the error just before the backtrace in bt2.txt:

2010-01-10 13:02:35.350 VDPAU Error: Error at util-vdpau.cpp:1364 (#3, An invalid handle value was provided.)

But since util-vdpau.* has been removed from trunk in the VDPAU refactoring, this issue has likely been fixed in trunk.

I'm closing the ticket as fixed, but if you can reproduce the crash on trunk (or on 0.23, when released), please open a new ticket. Thanks.

Note: See TracTickets for help on using tickets.