Opened 10 years ago

Closed 10 years ago

#7807 closed defect (fixed)

Delete playlist broken in watch recordings

Reported by: Marc Tousignant <myrdhn@…> Owned by: Isaac Richards
Priority: minor Milestone: 0.23
Component: MythTV - General Version: head
Severity: low Keywords: delete playlist
Cc: Ticket locked: no

Description

What I sometimes end up doing is watching several episodes of a single show and not deleting them when I'm done that show. Instead what I would do is, after I'm done watching, add all the shows I watched to the playlist and then going into the playlist window and deleting them. I recently updated from 22965 to 23004 and the delete option in the playlist menu nolonger deletes. I can select it but when I go back to watch recordings all the shows I told it to delete are still there.

Change History (3)

comment:1 Changed 10 years ago by Dibblah

Status: newinfoneeded_new

Can you please attach the output of mythbackend -v file

When the deletion is supposed to occur?

comment:2 Changed 10 years ago by Marc Tousignant <myrdhn@…>

There is nothing to post. Ran mythbackend --verbose file. On the frontend I added a recording to the playlist. I then went into playlist options and selected delete, nothing reported in logs. I added the same recording back into the playlist and then selected to delete and rerecord, and again I got nothing. If I select to delete the file normally I get

2009-12-29 00:33:31.864 SG(Default): FindRecordingFile: Searching for '2035_20091120090000.mpg'
2009-12-29 00:33:31.890 SG(Default): FindRecordingDir: Checking '/media/recorded' for '/media/recorded/2035_20091120090000.mpg'
2009-12-29 00:33:31.892 SG(Default): FindRecordingFile: Found '/media/recorded/2035_20091120090000.mpg'
2009-12-29 00:33:31.892 ProgramInfo: GetPlaybackURL: File is local: '/media/recorded/2035_20091120090000.mpg'
2009-12-29 00:33:39.074 ProgramInfo: Updated pathname '':'' -> '2035_20091120090000.mpg'
2009-12-29 00:33:42.026 ProgramInfo: Updated pathname '':'' -> '2035_20091120090000.mpg'
2009-12-29 00:33:42.047 About to delete file: /media/recorded/2035_20091120090000.mpg
2009-12-29 00:33:44.071 About to delete file: /media/recorded/2035_20091120090000.mpg.64.100x75.png
2009-12-29 00:33:44.097 About to delete file: /media/recorded/2035_20091120090000.mpg.64.png
2009-12-29 00:33:44.098 About to delete file: /media/recorded/2035_20091120090000.mpg.png

comment:3 Changed 10 years ago by danielk

Resolution: fixed
Status: infoneeded_newclosed

(In [23028]) Refs #7603. Fixes #7807. Moves more MythProto? calls out of UI thread in PlaybackBox? using an event driven helper thread to handle various calls.

Also fixes various bugs in the playlist handling following the MythUI port and one caused by [23009]. This also adds TODO's for some of the bugs that were not fixed.

Note: See TracTickets for help on using tickets.