Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#7822 closed defect (invalid)

Mythbackend cannot locate recordings for preview/delete, but can play them

Reported by: tjharris@… Owned by: sphery
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.22-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After upgrading to 0.22-fixes, I found that I could not delete all of my recorded programs (some work fine, others will fail).

For those programs that cannot be deleted, I also found that they do not show preview images, and I get errors saying the recording cannot be located.

But, they can be played by mythfrontend.

I verified that the chanid & start times referenced in the error messages were correct, matched the data in the DB, and the programs actually existed.

I initially had an old directory still listed in my storage groups, but I fixed that and the problem persisted.

Various actions and their related error messages:

--
Delete from MythWeb:
2009-12-29 09:22:24.682 mythbackend: Delete Recording: Unable to retrieve program info for chanid 1012 at Sun Dec 27 21:00:00 2009. Program will NOT be deleted.
--
View Recordings in MythWeb:
2009-12-29 09:23:32.896 MythXML::GetPreviewImage() - no recording for start time 2009-12-27T21:00:00
2009-12-29 09:23:32.908 MythXML::GetPreviewImage() - no recording for start time 2009-12-27T16:00:00
2009-12-29 09:23:34.070 MythXML::GetPreviewImage() - no recording for start time 2009-12-23T23:30:00
2009-12-29 09:23:34.194 MythXML::GetPreviewImage() - no recording for start time 2009-12-23T23:00:00
--
MythFrontend select Watch Recordings:
2009-12-29 09:24:56.627 Can not locate recording made on '1063' at '20091224230000'
2009-12-29 09:24:56.637 Can not locate recording made on '1063' at '20091224233000'
2009-12-29 09:24:56.648 Preview Error: Encountered problems running '/usr/local/bin/mythbackend --generate-preview 0x0 --chanid 1063 --starttime 20091224230000 '
2009-12-29 09:24:56.649 MainServer: Failed to make preview image.
2009-12-29 09:24:56.650 Preview Error: Encountered problems running '/usr/local/bin/mythbackend --generate-preview 0x0 --chanid 1063 --starttime 20091224233000 '
2009-12-29 09:24:56.650 MainServer: Failed to make preview image.
---
Delete recordings from mythfe:
2009-12-29 09:27:32.135 mythbackend: Delete Recording: Unable to retrieve program info for chanid 1003 at Sun Dec 27 16:00:00 2009. Program will NOT be deleted.


Backend: PowerPC G4 (Big Endian) running Ubuntu Linux.

--version:

  MythTV Version   : 22834
MythTV Branch    : branches/release-0-22-fixes
Network Protocol : 50
Library API      : 0.22.20091023-1
QT Version       : 4.4.3
Options compiled in:
 linux release using_oss using_alsa using_backend using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_live using_mheg

Tuner: HDHomeRun

Frontend: Linux (Atom/Ion? with VDPAU) and Mac OS X frontend; both same behavior.

Attachments (3)

mythbackend_7822.log (62.3 KB) - added by Eric Pheatt <eric.pheatt@…> 10 years ago.
mythbackend_20100601.log (26.7 KB) - added by Eric Pheatt <eric.pheatt@…> 10 years ago.
mythbackend_generate-preview-v_all.log (5.4 KB) - added by Eric Pheatt <eric.pheatt@…> 10 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 years ago by anonymous

Did some more debugging to try and narrow down the problem.

I ran the SQL query manually (as captured in debug output) and it successfully returned the correct program info.

I also used strace to see what was returned to mythbackend, and that showed the SQL query returning the program info. But, the location in the code where the error message is generated is when the query fails. I am not sure why it thinks the query failed.

comment:2 Changed 10 years ago by Stuart Auchterlonie

Milestone: 0.22.10.23

comment:3 Changed 10 years ago by sphery

Milestone: 0.23unknown
Status: newinfoneeded_new

tjharris, please provide a full backend log with -v important,general,file showing backend startup, attempting to delete the recording through Watch Recordings, then backend shutdown. Thanks.

comment:4 Changed 10 years ago by stuartm

Resolution: invalid
Status: infoneeded_newclosed

No response in 5 weeks.

Changed 10 years ago by Eric Pheatt <eric.pheatt@…>

Attachment: mythbackend_7822.log added

comment:5 Changed 10 years ago by Eric Pheatt <eric.pheatt@…>

Resolution: invalid
Status: closednew

I'm also encountering this problem after I upgraded to a recent .23-rc2 build from .21-fixes.

Backend: Freescale based PowerPC w/o Altivec (Big Endian) running Debian Linux using mythtv 0.23~rc2-0.3 packages from debian-multimedia.org.

MythTV Branch    : tags/release-0-23-rc2
Network Protocol : 56
Library API      : 0.23.20100314-1
QT Version       : 4.6.2
Options compiled in:
 linux release using_oss using_alsa using_pulse using_jack using_pulseoutput using_backend using_directfb using_dvb using_firewire using_fribidi using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live using_mheg
eric@KUROHG:~$ uname -a
Linux KUROHG 2.6.23-kuroboxhg #1 Wed Jan 23 13:33:05 PST 2008 ppc GNU/Linux

Tuner: HDHomeRun

Frontend: Linux (Appletv) and Mac OS X frontend; both same behavior.

comment:6 Changed 10 years ago by danielk

Status: newinfoneeded_new

Can you test with trunk? The relevant code has changed there as part of the program info refactor.

Most likely this is a confusion somewhere in the code where the scheduled start time is assumed to be the same as the recording start time.

comment:7 Changed 10 years ago by sphery

Resolution: invalid
Status: infoneeded_newclosed

9 weeks ago, I requested logs to help diagnose any issues. They weren't provided, and this ticket was closed. Then 4 weeks ago it was reopened, but the requested logs were never provided.

Anyone reopening this ticket should provide the logs requested in http://svn.mythtv.org/trac/ticket/7822#comment:3 .

Changed 10 years ago by Eric Pheatt <eric.pheatt@…>

Attachment: mythbackend_20100601.log added

Changed 10 years ago by Eric Pheatt <eric.pheatt@…>

comment:8 Changed 10 years ago by Eric Pheatt <eric.pheatt@…>

Resolution: invalid
Status: closednew

I've updated to the latest .23 from debian-multimedia.org and I am still encountering the issue.

mythtv@KUROHG:~$ /usr/bin/mythbackend --version
Please attach all output as a file in bug reports.
MythTV Version   : 0.23
MythTV Branch    : tags/release-0-23
Network Protocol : 56
Library API      : 0.23.20100429-1
QT Version       : 4.6.2
Options compiled in:
 linux release using_oss using_alsa using_pulse using_jack using_pulseoutput using_backend using_directfb using_dvb using_firewire using_fribidi using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

I have attached two files the mythbackend_20100601.log with the logging settings as directed from comment:3 and a second mythbackend_generate-preview-v_all.log for just the generate-preview with a -v all for a recording that cannot be deleted.

comment:9 Changed 9 years ago by mimo+mythtv-svn@…

Just to confirm. I have the same problem (on PowerPC). It used to work at one stage, now it's this.

/usr/bin/mythbackend --version
Please include all output in bug reports.
MythTV Version   : 24158
MythTV Branch    : branches/release-0-23-fixes
Network Protocol : 56
Library API      : 0.23.20100314-1
QT Version       : 4.6.2
Options compiled in:
 linux debug using_oss using_alsa using_pulse using_jack using_pulseoutput using_backend using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libudev using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live using_mheg
2010-07-28 21:31:45.171 MythXML::ProcessRequest: GetPreviewImage : GET /Myth/GetPreviewImage?ChanId=1015&StartTime=2010-07-25T23%3A35%3A00&Height=56&Width=100& HTTP/1.0

2010-07-28 21:31:45.195 MSqlQuery::exec(DBManager0) SELECT r.chanid,           r.starttime,   r.endtime,                r.title,            r.subtitle,    r.description,            c.channum,          c.callsign,    c.name,                   c.commmethod,       c.outputfilters,                         r.seriesid,         r.programid,   r.filesize,               r.lastmodified,     r.stars,       r.previouslyshown,        r.originalairdate,  r.hostname,    r.recordid,               r.transcoder,       r.playgroup,   r.recpriority,            r.progstart,        r.progend,     r.basename,               r.recgroup,         r.storagegroup,                          r.commflagged,      r.cutlist,     r.autoexpire,             r.editing,          r.bookmark,    r.watched,                r.preserve,         r.transcoded,  r.deletepending,          p.audioprop+0,      p.videoprop+0, p.subtitletypes+0  FROM recorded AS r LEFT JOIN (channel AS c, recordedprogram AS p) ON (r.chanid    = c.chanid AND     r.chanid    = p.chanid AND     r.progstart = p.starttime) WHERE r.chanid    = '1015' AND       r.starttime = '2010-07-25T23:35:00' <<<< Returns 1 row(s)
2010-07-28 21:31:45.226 MythXML::GetPreviewImage() - no recording for start time 2010-07-25T23:35:00
2010-07-28 21:31:45.247 HTTPRequest::SendResponse(xml/html) () :404 Not Found -> 192.168.0.106: 2

comment:10 Changed 9 years ago by robertm

Owner: changed from Isaac Richards to sphery
Status: newassigned

comment:11 Changed 9 years ago by sphery

Priority: majorminor
Resolution: invalid
Status: assignedclosed

Still no log against trunk provided in 3 months (as requested in comment:6). Since programinfo handling has changed significantly, and mythbackend_7822.log seems to indicate a problem with programinfo retrieval, and since mythbackend_20100601.log and mythbackend_generate-preview-v_all.log seem to indicate missing files or incorrect storage group configurations, I'm closing this as invalid for now. If someone can reproduce on current trunk or 0.24 (when released), they can reopen the ticket.

comment:12 Changed 8 years ago by mab893@…

Eventually found the problem that was causing this for me: recorded.hostname needs to match the current value of your backend hostname. If you had recordings that were under a different hostname, you need to update them with something like:

update recorded set hostname='YOURHOSTNAME' where hostname='YOUROLDHOSTNAME';

Otherwise, it thinks the recording is hosted elsewhere.

For me, my hostname had changed from a short name to a fully qualified host name.

Note: See TracTickets for help on using tickets.