Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7829 closed defect (duplicate)

DVD playback issues with Pixar DVDs

Reported by: alan@… Owned by: skamithi
Priority: minor Milestone: unknown
Component: MythTV - DVD Playback Version: 0.22-fixes
Severity: high Keywords:
Cc: Ticket locked: no

Description

All three Pixar DVDs I own have some level of playback issues with MythTV, and no issues (that I know of) with Xine or Totem (Gstreamer). Issues are consistent on two different myth front ends (one AMD 64 bit dual core + nvidia, one 32 bit Intel P4 + SIS) - both run Mythbuntu based Myth images. AMD unit is dedicated Mythbuntu frontend - clean install with 9.10/MythTV 0.22-fixes, using bog standard CPU+ profile (i.e. Bob x2 deint for all video types), Intel is Ubuntu 9.10 for normal PC usage - myth is only run here for testing - log is from the Intel PC (hence warnings about gutless graphics).

Issue 1. - Major Monster's Inc. Collector's Edition does not play at all. When first launched from MythTV's Play DVD menu, at most the FBI warning flashes briefly on the screen and then drops back to MythTV's menu. Using a ripped ISO of the same disc, the FBI warning is not flashed before dropping back to MythVideo? menu. Attached is a log with -v playback,extras of the ISO attempting to be played - please note in the log I also launched another ISO via MythVideo? that works perfectly for comparison (i.e. its not a storage groups issue).

Issue 2 - trivial annoyance On Wall-E (original release in cardboard packaging) and Finding Nemo Collector's Edition, pressing play from the DVD's main menu puts MythDVD in to the FBI/copyright loop, this loops until either the DVD menu or exit button is selected. By contrast, choosing "select scene" from the DVD main menu, and then scene 1, allows the movie to play correctly.

Issue 3 - minor problem On both discs, choosing the THX Optimizer (under setup), which has a series of still frames etc., doesn't work correctly, either the setup screens are not shown, or skipped passed immediately, or you are thrown back to myth menus.

I suspect that these are related, as they appear to be menu oriented - but don't know if they need to be made in to three separate bug reports, let me know.

Thanks

Alan

Attachments (1)

monsters_inc_log_091230.log.gz (3.5 KB) - added by alan@… 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by alan@…

comment:1 Changed 9 years ago by skamithi

please confirm if the same issues exist in 0.23?

comment:2 Changed 9 years ago by skamithi

Resolution: duplicate
Status: newclosed

pls run 0.23 or trunk and run the patch found in #8248.

dup of #8248.

comment:3 Changed 9 years ago by alan@…

Pre-patch makes no difference whatsoever on Monster's Inc. with 0.23-fixes23789 from mythbuntu. Actually, both disc and ISO simply drop back to the Mythvideo menu.

It'll be some time before I'll be able to apply the patch and build it.

Note: See TracTickets for help on using tickets.