Opened 10 years ago

Closed 10 years ago

#7890 closed defect (fixed)

DVD playback can lock with Waited too long for vide out to unpause

Reported by: John Harvey <john.p.harvey@…> Owned by: skamithi
Priority: minor Milestone: unknown
Component: MythTV - DVD Playback Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When fast forwarding the dvd playback can lock continually printing the above message. This is caused by fast forward code doing PauseVideo?, FFwf, UnPauseVideo?. If the FFwd take you to a still frame, while the UnpauseVideo? is happening the videout thread does a Pause which causes the UnPause? to never happen.

The Videout loop checks PauseVideo? which is really a request state from the decode and thinks we are unpaused when we are still actually paused and therefore breaks the request to unpause. Changing this to check the actual state (video_actually_paused) fixes this problem. I also changed PauseVideo? to not set video_actually_paused if we are not waiting since i believe this is used so we wait for a frame interval and check that it reputs us inot pause state. Since the not waiting is only called from the videout loop we dont need to wait for that to happen and since we can call that without a lock changing it could break another call to UnpauseVideo?

Attachments (1)

patch.diff (860 bytes) - added by John Harvey <john.p.harvey@…> 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by John Harvey <john.p.harvey@…>

Attachment: patch.diff added

comment:1 Changed 10 years ago by skamithi

(In [23160]) Refs #7890. resolve dvd playback can lock with "waited too long for videoout to unpause". patch from john harvey. will apply to 0.22 fixes soon.

comment:2 Changed 10 years ago by skamithi

Resolution: fixed
Status: newclosed

(In [23424]) Closes #7890. apply [23160] to 0.22 fixes. resolve dvd playback can lock with "waited too long for videoout to unpause". patch from john harvey

Note: See TracTickets for help on using tickets.