Opened 10 years ago

Closed 9 years ago

#7893 closed defect (Works for me)

mythcommflag segfaults and finds 0 commercials

Reported by: Ronald Frazier <ron@…> Owned by: cpinkham
Priority: minor Milestone: unknown
Component: MythTV - Mythcommflag Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I've had a number of instances of mythcommflag segfaulting. I started looking at which ones were failing, and in the most recent 3 cases I've noticed the status in the database says that it found 0 commercial breaks. I'm not sure if the 0 commercials has something to do with the cause, or if it's merely a side effect of the crash (one of these was legitimately commercial free, but not the other 2).

The dmesg output from these 3 crashes is:

[1416210.765986] mythcommflag[13521]: segfault at 0 ip b61eb996 sp b2e1bd80 error 4 in libmythdb-0.22.so.0.22.0[b61ba000+a6000]

[1503354.210456] mythcommflag[13022]: segfault at 72006f0c ip b4f21ec2 sp b2e80b14 error 4 in libc-2.7.so[b4eb3000+155000]

[1505206.313011] mythcommflag[12567]: segfault at c3 ip b4f95ec2 sp bfdef2c0 error 4 in libc-2.7.so[b4f27000+155000]

I'm attaching the debug output.

Attachments (4)

mythcommflag_core1.txt (1.4 KB) - added by Ronald Frazier <ron@…> 10 years ago.
mythcommflag_core2.txt (394 bytes) - added by Ronald Frazier <ron@…> 10 years ago.
mythcommflag_core3.txt (3.2 KB) - added by Ronald Frazier <ron@…> 10 years ago.
myth_bt.txt (13.9 KB) - added by mythtv@… 9 years ago.
gdb backtrace

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by Ronald Frazier <ron@…>

Attachment: mythcommflag_core1.txt added

Changed 10 years ago by Ronald Frazier <ron@…>

Attachment: mythcommflag_core2.txt added

Changed 10 years ago by Ronald Frazier <ron@…>

Attachment: mythcommflag_core3.txt added

comment:1 Changed 10 years ago by robertm

Status: newinfoneeded_new

Hi Ron,

It's going to be really, really hard to diagnose this without debug symbols and a proper backtrace per the manual and wiki debugging page. Can you please provide?

comment:2 Changed 10 years ago by Ronald Frazier <ron@…>

I tried posting the following on the dev forum (as I thought discussion was discouraged in trac), but nobody has given an answer in over a week, so I'm posting here:

What do you mean, exactly? What is missing? As far as I can tell, I've followed the instructions here: http://www.mythtv.org/wiki/Debugging

I did a make distclean, ran configure with --compile-type=debug, then a make and make install, made sure everything was stopped, then restarted the backend. I just double checked my command history and that is indeed what I did.

I set it to dump a core. I ran the core through gdb and generated the backtrace. If you look in the first log, you can see that there is debug info for myth with line numbers. Why the 2nd and 3rd logs have so little info in it, I have no idea, but I followed the same instructions I used to generate the first log. I didn't think you'd need the dozens of

Reading symbols from /usr/local/lib/libmythtv-0.22.so.0...done.
Loaded symbols for /usr/local/lib/libmythtv-0.22.so.0
Reading symbols from /usr/local/lib/libmythavformat-0.22.so.0...done.
Loaded symbols for /usr/local/lib/libmythavformat-0.22.so.0

lines, so I omitted them. If you can tell me what I did wrong, I'd be more than happy to retry.

comment:3 Changed 10 years ago by robertm

Status: infoneeded_newnew

Ron,

You're right, BT looks fine, I didn't read them all all the way through. Thanks.

Changed 9 years ago by mythtv@…

Attachment: myth_bt.txt added

gdb backtrace

comment:4 Changed 9 years ago by mythtv@…

Segfaults from time to time here too using branches/release-0-23-fixes [24254M]. Not on all shows though and usually it segfaults immediately. Attaching backtrace.

comment:5 in reply to:  4 Changed 9 years ago by Janne Grunau

Replying to mythtv@…:

Segfaults from time to time here too using branches/release-0-23-fixes [24254M]. Not on all shows though and usually it segfaults immediately. Attaching backtrace.

That segfault is unrelated, please open a seperate ticket

comment:6 Changed 9 years ago by robertm

Status: newassigned

comment:7 Changed 9 years ago by cpinkham

Status: assignedinfoneeded

Can you confirm this is still happening with the latest trunk code? Since there is nothing else in the backtrace, it appears this is happening when mythcommflag is shutting down. Can you confirm this by running mythcommflag with the "-v file,extra,commflag" option on a file you can reproduce this issue with? We've made several changes over the past few months in areas of the code that might affect this and are not experiencing any broad reports of issues like this, so I believe this issue (if it was in the code) has been solved.

comment:8 Changed 9 years ago by cpinkham

Resolution: Works for me
Status: infoneededclosed

Closing this as 'works for a lot of people' and I believe this issue was resolved quite a while back. If the issue can be reproduced with current trunk, the ticket can be reopened.

Note: See TracTickets for help on using tickets.