Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#79 closed patch (fixed)

patch to make LCD progressbars correct

Reported by: myth@… Owned by: Isaac Richards
Priority: trivial Milestone: unknown
Component: mythtv Version: 0.18.1
Severity: low Keywords: lcd
Cc: Ticket locked: no

Description

This fixes the LCD progress bar when myth is displaying a MythProgressDialog?. It's based of a previous reject patched and fixed according to Isaac's comments :

--- 8< ---

On Tue, 2005-05-03 at 03:17 -0400, Isaac Richards wrote:

I've applied this, minus:

  • fix in mythdialogs to ensure that generic progress bars look proper on

LCD.

The / 1000's there to keep it from updating the UI too often.

Do you mean the LCD or the UI ? The "curprogress % steps" check is only there for the QT, so it'll update normally, where as the LCD will update every time it's called (and the LCD is probably much slower than QT).

The problem is, that the rounding makes the progress bar incorrect.

Ie.

MythProgressDialog? p ("foo", 1500); int steps = 1500/1000 = 1. p->setProgress (1100); float fProgress = 1100/(1*1000.0) = 110% instead of 73%.

so the LCD progress bar finishes too early depending on the total steps.

How about if I change the patch so the LCD also only gets updated if "curprogress % steps == 0", but then keep the tsteps so the LCD updates correctly ?

And thanks for applying the patches.

--- 8< ---

Attachments (1)

lcd3.patch (1.7 KB) - added by myth@… 14 years ago.
patch for LCD progress bars

Download all attachments as: .zip

Change History (2)

Changed 14 years ago by myth@…

Attachment: lcd3.patch added

patch for LCD progress bars

comment:1 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: newclosed

(In [6805]) Patch from myth at eskil dot org, to make the LCD progress bars correct. Closes #79.

This bumps up the libmyth version.

Note: See TracTickets for help on using tickets.