Opened 11 years ago

Closed 11 years ago

#7902 closed defect (duplicate)

Mythtv 0.22 svn r23110 fails to compile

Reported by: zeno979@… Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: MythTV - General Version: 0.22-fixes
Severity: medium Keywords: compilation
Cc: Ticket locked: no

Description

configure flags: ./configure --arch=pentium4 --cpu=pentium4 --tune=pentium4 --extra-cflags='-fomit-frame-pointer -ffast-math' --extra-cxxflags='-fomit-frame-pointer -ffast-math'

error: .. cd mythavtest/ && make -f Makefile make[2]: Entering directory `/home/weem/mythtv/mythtv_0.22.0+fixes23110/programs/mythavtest' sh "/home/weem/mythtv/mythtv_0.22.0+fixes23110/version.sh" "/home/weem/mythtv/mythtv_0.22.0+fixes23110" ": http://svn.mythtv.org/svn/branches/release-0-22-fixes/mythtv/version.pro " ccache g++ -Wl,-O1 -o mythavtest version.o main.o -L/usr/lib -L../../libs/libmyth -L../../libs/libmythtv -L../../libs/libavutil -L../../libs/libavcodec -L../../libs/libavformat -L../../libs/libswscale -L../../libs/libmythdb -L../../libs/libmythui -L../../libs/libmythupnp -lmythtv-0.22 -lmythavformat-0.22 -lmythavutil-0.22 -lmythavcodec-0.22 -lmythswscale-0.22 -lmythupnp-0.22 -lmyth-0.22 -lmythui-0.22 -lmythdb-0.22 -L../../libs/libmythfreemheg -lmythfreemheg-0.22 -L../../libs/libmythhdhomerun -lmythhdhomerun-0.22 -lfreetype -lz -lraw1394 -liec61883 -lavc1394 -lrom1394 -L/usr/lib -ldirectfb -lfusion -ldirect -L/usr/X11R6/lib -lXinerama -lX11 -lXext -lXxf86vm -lXv -lXrandr -lpulse -L/usr/local/lib -lpthread -lGLU -lGL -lQtSql -lQtXml -lQtOpenGL -lQtGui -lQtNetwork -lQtCore ../../libs/libmyth/libmyth-0.22.so: undefined reference to `vtable for soundtouch::TDStretchMMX' ../../libs/libmyth/libmyth-0.22.so: undefined reference to `FIRFilterMMX::FIRFilterMMX()' collect2: ld returned 1 exit status make[2]: * [mythavtest] Error 1 make[2]: Leaving directory `/home/weem/mythtv/mythtv_0.22.0+fixes23110/programs/mythavtest' make[1]: * [sub-mythavtest-make_default] Error 2 make[1]: Leaving directory `/home/weem/mythtv/mythtv_0.22.0+fixes23110/programs' make: * [sub-programs-make_default-ordered] Error

Change History (1)

comment:1 Changed 11 years ago by Raymond Wagner

Resolution: duplicate
Status: newclosed

Duplicate of #7901.

Note: See TracTickets for help on using tickets.