Opened 10 years ago

Closed 10 years ago

#7918 closed defect (fixed)

Mythbuntu theme doesn't update correctly

Reported by: Kenni Lund <kenni@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: Themes Version: unknown
Severity: medium Keywords: Mythbuntu theme update sync
Cc: nikolaj_koch@… Ticket locked: no

Description

As seen in the attached screenshot, the Mythbuntu theme doesn't update the selection bar correctly. It happens all the time when deleting recordings and moving the selection bar up and down.

I can replicate the issue on both 0.22-fixes (r23110) and trunk (r23151) and a friend of mine just confirmed that he has the same issue on his Mythbuntu-box with latest autobuild from 0.22-fixes (r23117).

Screen resolution doesn't seem to matter, the issue exists on both 1920x1080 and 1360x768, I haven't tested other resolutions.

Attachments (2)

mythbuntu_widescreen_01.jpg (112.0 KB) - added by Kenni Lund <kenni@…> 10 years ago.
Screenshot of updating problem
recordings-ui.xml.patch (1.6 KB) - added by Gary Butters <gbutters@…> 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Kenni Lund <kenni@…>

Attachment: mythbuntu_widescreen_01.jpg added

Screenshot of updating problem

comment:1 Changed 10 years ago by Kenni Lund <kenni@…>

A similar problem was apparently fixed ~3 months ago according to https://bugs.launchpad.net/mythbuntu/+bug/440342 , but it could seem like this fix never made it upstream or that it didn't fix the issue completely.

I've noticed that switching to another desktop in KDE and back again redraws the screen and fixes the selection bar. I don't know if this helps anything in identifying the issue. Also, in trunk, if the selected recording has fanart (eg. a background), the selection bar is fixed at the same second the background is added.

This issue should be fairly easy to replicate, as even Mythbuntu with autobuild repositories enabled has this issue, but please contact me if further information is needed.

comment:2 Changed 10 years ago by Kenni Lund <kenni@…>

In order to reproduce this issue, the painting engine must be set to QT..the issue doesn't exist when using OpenGL.

comment:3 Changed 10 years ago by Gary Butters <gbutters@…>

Patch attached

Changed 10 years ago by Gary Butters <gbutters@…>

Attachment: recordings-ui.xml.patch added

comment:4 Changed 10 years ago by robertm

(In [23472]) Refs #7918. Fix buttonarea issue in Mythbuntu theme that led to redraw errors with the Qt painter.

comment:5 Changed 10 years ago by robertm

Resolution: fixed
Status: newclosed

(In [23473]) Fixes #7918. Fixes backport for buttonarea issue in Mythbuntu theme that led to redraw errors with the Qt painter.

Note: See TracTickets for help on using tickets.