Opened 10 years ago

Closed 10 years ago

#7924 closed defect (invalid)

Mythweather crashes if some files in filesystem have incorrect permissions

Reported by: Antony Gelberg <antony.gelberg@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: Plugin - MythWeather Version: 0.22-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I must have messed up my svn tree somehow, the end result being that several files in mythweather/scripts/* had executable permissions, not just the .pl files as intended. SourceManager::recurseDirs contains the line if (file.isExecutable() && !(file.isDir())) which, in the above case, results in mythweather attempting to execute files that it shouldn't, e.g. ENVCAN-Maps.xml.

I know that this was caused by a problem in my svn tree, but I don't think that mythweather should crash if a script that it tries to execute fails.

Change History (2)

comment:1 Changed 10 years ago by paulh

Status: newinfoneeded_new

Any chance of getting a backtrace of the crash? http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

comment:2 Changed 10 years ago by robertm

Resolution: invalid
Status: infoneeded_newclosed

No response, and broken permissions is definitely not an easily supportable configuration.

Note: See TracTickets for help on using tickets.