Opened 11 years ago

Closed 11 years ago

#7931 closed defect (worksforme)

MythVideo DOWNLOADDATA crashes when accessed via LIRC remote multiple times

Reported by: John Kerenyi <jkerenyi123@…> Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: Plugin - MythVideo Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Pressing the remote key mapped to DOWNLOADDATA in MythVideo? works the first time and then inevitably crashes Mythfrontend the second time. The log reports:

terminate called after throwing an instance of 'std::bad_alloc'

what(): std::bad_alloc

The crash takes about 5-10 minutes to occur; in the meantime Mythfrontend is unresponsive although the system is accessible via ssh.

Using the keyboard causes no issues.

I am attaching the output of mythfrontend -v most to this report; it consists of a session that went to MythVideo?, navigated a directory structure, and activated DOWNLOADDATA twice, the second time resulting in a crash. Note that for some reason this form of logging did not log the "terminate called after..." reported above.

Attachments (1)

frontend-debug.log (332.4 KB) - added by John Kerenyi <jkerenyi123@…> 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by John Kerenyi <jkerenyi123@…>

Attachment: frontend-debug.log added

comment:1 Changed 11 years ago by robertm

Status: newinfoneeded_new

Unable to reproduce. This really sounds like some sort of local configuration issue/problem. Need a trace of the process or some sort of further information if I'm going to be able to do anything with this. The code is triggered in the exact same way whether it's called by LIRC or the keyboard. I would check for binding conflicts, too.

comment:2 Changed 11 years ago by robertm

Resolution: worksforme
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.