Opened 10 years ago

Closed 10 years ago

#7979 closed defect (fixed)

With "monitor CD/DVD" enabled, mythfrontend hangs while exiting

Reported by: yianniv Owned by: Nigel
Priority: minor Milestone: 0.23
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

The last lines of mythfrontend -v all show:

2010-01-27 20:56:48.355 /dev/fd0 No info or drive not ready
2010-01-27 20:56:48.363 /dev/sr0 No disc
2010-01-27 20:56:48.864 MythCDROMLinux::driveStatus() - ioctl() failed:
                        eno: Îη έγκÏÏη ÏαÏάμεÏÏÎ¿Ï (22)
2010-01-27 20:56:48.864 /dev/fd0 No info or drive not ready
2010-01-27 20:56:48.873 /dev/sr0 No disc
2010-01-27 20:56:49.010 Stopping MediaMonitor

and the terminal just stays there... I have to kill it with CTRL+C in the terminal.

I reproduced the problem on two opensuse 11.2 pcs, (desktop + laptop).

From the desktop pc:

MythTV Version   : 23321M
MythTV Branch    : trunk
Network Protocol : 56
Library API      : 0.23.20100124-2
QT Version       : 4.6.1
Options compiled in:
 linux release using_oss using_alsa using_jack using_backend using_directfb using_dvb using_frontend using_hdpvr using_iptv using_ivtv using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

The laptop is on 23310, no VDPAU.

To reproduce, if "monitor CD/DVD" is not checked, check it, exit and restart the frontend. Then it will hang on exit.

It doesn't matter if devices are excluded from monitoring or not (I tried excluding /dev/sr0, and /dev/fd0).

It' s a fairly recent problem, no more than a week old - I think - , but I apologize I can't be more specific. However, I update almost daily.

Yianni.

Change History (5)

comment:1 Changed 10 years ago by Nigel

Milestone: unknown0.23
Owner: changed from Isaac Richards to Nigel
Status: newassigned

23214 exhibits the fault, 23120 and 23137 do not.

comment:2 Changed 10 years ago by anonymous

Looks like the event changes in [23211] did it, along with a few other faults (e.g. recording items not being removed from playbackbox when deleted)

comment:3 Changed 10 years ago by anonymous

Recent [23348] does not fix this.

comment:4 Changed 10 years ago by danielk

Ticket locked: set

comment:5 Changed 10 years ago by Nigel

Resolution: fixed
Status: assignedclosed

In my testing, this was fixed in -r23348. Perhaps do make clean in programs/mythfrontend? The PlaybackBox? fault needs a fresh ticket.

Note: See TracTickets for help on using tickets.