Opened 10 years ago

Closed 10 years ago

#7993 closed defect (fixed)

Minimyth error "Video frame buffering failed too many times" on aspect ratio switch

Reported by: Chris Dennis <cgdennis@…> Owned by: markk
Priority: minor Milestone: 0.24
Component: MythTV - General Version: 0.22-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Since upgrading to 0.22, my main MythTV frontend gives the error "Video frame buffering failed too many times" when fast-forwarding past a change in aspect ratio.

For example, "Family Guy" is broadcast on BBC Three via DVB-S as a 4:3 aspect ratio picture. The trailers before the programme are 16:9. If I try to fast-forward past the trailers, the picture freezes when it gets to the 4:3 content, then returns to the menu with the error message as above in a green box.

A mythfrontend log of this happening (at timestamp 11:09:46.132) is attached.

This happens on a frontend which is an EPIA-M6000G motherboard, attached to an LCD TV via VGA cable at 1360x768, running MiniMyth? 0.22-73b4. The same thing has happened with previous versions of MiniMyth? (0.22-72, 0.22-73b3), and also when the same frontend was running 'proper' MythTV on its own hard drive.

Other frontends, e.g. my desktop PC and my laptop running Ubuntu 9.10 and MythTV 0.22-fixes, don't see this error.

The error did not occur with 0.21.

The backend is running MythBuntu? 9.10 with MythTV 0.22-fixes.

I'll try to make a small recording that causes the error available.

Attachments (3)

syslog-vfbftmt (73.2 KB) - added by Chris Dennis <cgdennis@…> 10 years ago.
mythfrontend log with "video frame buffering failed too many times" error
xorg.conf (4.5 KB) - added by Chris Dennis <cgdennis@…> 10 years ago.
mythfrontend's xorg.conf file with modelines
syslog-vfbftmt-v (188.7 KB) - added by Chris Dennis <cgdennis@…> 10 years ago.
Verbose mythfrontend log with error at 16:21:02.747

Download all attachments as: .zip

Change History (17)

Changed 10 years ago by Chris Dennis <cgdennis@…>

Attachment: syslog-vfbftmt added

mythfrontend log with "video frame buffering failed too many times" error

Changed 10 years ago by Chris Dennis <cgdennis@…>

Attachment: xorg.conf added

mythfrontend's xorg.conf file with modelines

comment:1 Changed 10 years ago by Chris Dennis <cgdennis@…>

I've extracted a fragment of a recording that displays the error, and put it at http://fbcs.co.uk/files/7319_20100125232800.mpg

If I view that recording on my MiniMyth? frontend and fast-forward at 20x, it gives the error described above.

comment:2 Changed 10 years ago by markk

Owner: changed from Isaac Richards to markk
Status: newaccepted

comment:3 Changed 10 years ago by markk

Milestone: unknown0.23

comment:4 Changed 10 years ago by markk

Chris

Thanks for the clip. Could you please post the full output of 'mythfrontend -v playback'. I need the extra detail around the resolution change.

Thanks, Mark

Changed 10 years ago by Chris Dennis <cgdennis@…>

Attachment: syslog-vfbftmt-v added

Verbose mythfrontend log with error at 16:21:02.747

comment:5 Changed 10 years ago by Chris Dennis <cgdennis@…>

Mark

I've attached a verbose log as requested. Because the clip is short, it seems less reliable at reproducing the error -- I think sometimes playback hits the end of the file instead of hitting the problem. On this occasion, I had to try three times, fast-forwarding x5 or x10 as soon as playback started: on the third attempt the error message appeared. As a result, the log probably contains a lot of stuff that may not be relevant. The error in questions occurs at timestamp 16:21:02.747 in the log.

cheers

Chris

comment:6 Changed 10 years ago by markk

There have been a couple of fixes in this area and I can't reproduce the issue myself. Pushing back to 0.24 to see if Chris can confirm whether or not it is fixed in 0.23.

comment:7 Changed 10 years ago by markk

Milestone: 0.230.24

comment:8 Changed 10 years ago by Chris Dennis <cgdennis@…>

I haven't got a 0.23 system with the same hardware to try it out on, so I'll just keep using the latest 0.22-fixes and report back if it gets fixed.

cheers

Chris

comment:9 Changed 10 years ago by robertm

Status: acceptedinfoneeded

Chris,

Any fix in .23 is unlikely to find its way to .22-- This ticket is probably going to stay in limbo unless you are able to test with .23.

comment:10 Changed 10 years ago by robertm

Resolution: fixed
Status: infoneededclosed

no response, please re-open if this issue occurs with .23-RC3 or later.

comment:11 Changed 10 years ago by robertm

Resolution: fixed
Status: closednew

comment:12 Changed 10 years ago by robertm

Status: newassigned

Tom Lichti on the mailing list reports this issue exists in trunk.

comment:13 Changed 10 years ago by Chris Dennis <cgdennis@…>

I've now updated my backend box to Ubuntu 10.04 with mythtv 0.23-fixes, and the frontend to minimyth 0.23-73b9.

And I can report that the problem has gone away!

Thank you to everyone involved in 0.23 -- it's looking very good so far.

comment:14 Changed 10 years ago by markk

Resolution: fixed
Status: assignedclosed

Thanks to Chris for reporting back.

Note: See TracTickets for help on using tickets.