Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7996 closed defect (fixed)

GUI Offset Not Working

Reported by: Britney Fransen <britney.fransen@…> Owned by: paulh
Priority: minor Milestone: 0.23
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I upgraded from .22-fixes to trunk (23359) and it seems that the x & y offset settings (Setup-->Appearance-->Screen Settings) are not being applied in trunk. The height and width are working but GUI is pined to 0,0 offset on the screen. I checked the db and GuiOffsetX & GuiOffsetY do have values (50 & 21). Running mythfrontend -geometry 1850x1030+50+21 works correctly.

Attachments (1)

mythmainwindow.diff (1.6 KB) - added by Britney Fransen <britney.fransen@…> 10 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by sphery

After some discussion in IRC, Britney reported that non-zero GUI height and width (smaller than screen size) are specified, that the issue always happens when started (so it's not a dup of #6508 ), and that when started with "Use window border" enabled (RunInWindow?), the GUI offsets work properly.

comment:2 Changed 10 years ago by Britney Fransen <britney.fransen@…>

I am using Fluxbox as my window manager.

comment:3 Changed 10 years ago by markk

I've confirmed that this looks like an issue with Fluxbox. Metacity works as expected with a variety of settings, either overridded from the command line or set via Screen Settings.

Switching to Fluxbox and, as described, x and y offsets set via the Screen Setup page are not respected unless 'Use Window Border' is set. --geometry works as expected. Furthermore, the UI is tiled across the screen if 'fixed window size' is not set.

comment:4 Changed 10 years ago by yan@…

I can confirm this same issue with openbox as the wm. Worked in 0.22, doesn't work in 25320..

comment:5 Changed 10 years ago by stuartm

Ticket locked: set

Failed to read the TicketHowTo, banned for 30 days.

(If only)

comment:6 Changed 10 years ago by danielk

Ticket locked: unset

comment:7 Changed 10 years ago by Britney Fransen <britney.fransen@…>

Attached is a patch that fixes this in Fluxbox and I would guess other *box WMs but I have only tested it on Fluxbox. In Fluxbox when Qt::WindowFullScreen? is set it ignores any offsets and places the window at 0,0.

Currently the "Use window border" setting is being used to determine if the Qt::WindowFullScreen? should be set but that is not how the setting is described in the help text. This patch looks at the offset and dimensions and if they are 0 sets the Qt::WindowFullScreen?. The "Use window border" just shows or hides the window border.

Changed 10 years ago by Britney Fransen <britney.fransen@…>

Attachment: mythmainwindow.diff added

comment:8 Changed 10 years ago by paulh

Owner: changed from Isaac Richards to paulh
Status: newassigned

comment:9 Changed 10 years ago by paulh

Resolution: fixed
Status: assignedclosed

(In [23578]) Fix the GUI offset settings not working properly when not running in a window. Patch from Britney Fransen. Fixes #7996, #6508.

comment:10 Changed 10 years ago by sphery

(In [23765]) Fixes fullscreen window mode.

The check for whether to make the window fullscreen added in [23578] was not working properly since the "real" (full-screen-sized) values for screen width and height were set by the time GetScreenSettings?() was called, so they were no longer the full screen flag value, 0. This changes the check to rely, instead, on the settings values, and also adds some logging output to make debugging future issues easier.

Refs #7996. Refs #8021 (though the change may not fix Compiz, mythfrontend should now properly request fullscreen mode when appropriate). Thanks to stuarta and EnderTheThird? for reporting the issue.

Note: See TracTickets for help on using tickets.